Question Laptop CPU on Max Clock Speed

Aug 8, 2020
1
0
10
0
I just got a new laptop yesterday from GentechPC I got a Sager NP8358F2-S (Clevo PB51DF2) which comes with i7 10875H and RTX 2070 Super. This happens while laptop is plugged in.

The laptop frequency is always at 4800 MHz. The only way I managed to get this down is to use ThrottleStop and disable turbo which brings it to 2300MHz on idle. Task Manager and NZXT CAM both show usage under 5%. I open my battery and change the slider to the left and right makes no difference. The only other way I seem to be able to get it down is if I go into power options > Edit settings > Change Advanced Power Settings > Processor Power Management and lower the maximum. There is only one power setting Balanced not sure if it's because my computer comes with Control Center 3.0. If I change the power modes in the control center 3.0 also makes no difference. SpeedStep also shows as being enabled in throttlestop and I see no option to edit this in the BIOS. I'm not sure what to do as I don't want the processor always at MAX but would like it to be able to go to max if needed when gaming or rendering.
Anyone able to help me with this? Very frustrated as this is a brand new laptop and not sure how to fix this. Temps are around 45 idle and go up to 60 when turbo is enabled + fans are load.
 
Sep 28, 2019
2
0
10
0
Yeah, my laptop was also on max frequency even in idle... I think what you looking for is speedshift (SS) values in throttlestop.. for example: when you set SS to 0 cpu goes in maximum frequency all the time, SS 32 is for me a sweet spot between gaming perfomance and idle, browsing etc.
You can also set SS to 64 or even 128 but that makes your cpu slow AF x)...
 

ASK THE COMMUNITY