• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question Laptop freezes when connected to internet cable

Oct 8, 2019
1
0
10
0
I'm in a student dorm and they have internet for the students through internet cable. I've been in this dorm for 4 years I'm starting my 5th now and in all of those years I've never had a problem like this.

I have a router Linksys Compact Wireless-G Broadband Router model WRT54GC version 2.0 and a Lenovo laptop G50-80, for about a month I've been using it and it's been working perfectly but that's when there weren't a lot of students in the dorm and now there are around 100 students.

This problem started yesterday first my WiFi was acting up it said connected and there was no internet then I tried restarting it and it connected and it loaded in Google and when I tried opening YouTube the WiFi just crashed and it said connecting. I got tired of this and decided to just connect my laptop directly with a cable and then I noticed my mouse started lagging, a lot, and it just stopped, once I disconnected the cable it went back to normal instantly I also restarted my laptop while the cable was plugged and my laptop wouldn't load, it was just a black screen with the mouse on the loading icon but once plugged out it loaded in right away.

I also managed somehow to connect with the cable without it freezing my laptop but just the mouse lagging a lot and the networks name was "f*** you 2" the first thing that came to mind was one of the IT students that are staying in the dorm decided to mess around with the network but I'm not sure, another thing is at the same time I opened up my task manager and saw my CPU was at 100% I scrolled to see what was causing this and I'm not sure if this was the correct one but I think it said "system interrupts" was at 100% it might have been a different process but that's the closest I can remember. After I unpluged the cable the CPU went back to 20-30%, I tried a different cable too it's the same problem and different ethernet port with two different cables and no dice. I'll keep trying to get the task manager working to see the correct name of the process.

I've tried changing cables I've tried using different ethernet ports even my roommate tried to connect his laptop and the same thing happened.

Please help I can't keep using my data from my phone, it's essential to my school work and work. Thank you in advance.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS