[SOLVED] Laptop GPU runs slower when power not plugged in

rjcard32315

Prominent
Jul 29, 2018
76
0
540
1
I just got a new dell laptop G3 with a 1660 ti and i5 9300f, when ever i unplug the power connector and it runs off of battery games literally cant run. it depends of coarse but on games like sea of thieves its at 13 fps when unplugged and it caps at 60 fps when plugged. I get its to conserve power but for now when i need it to run games unplugged i want to at least know how to disable and enable that option. If anyone knows please let me know it came with a bunch of software well really only alien ware command center and i already messed with power options and there doesn't seem to be a fix there. Any suggestions are greatly appreciated thanks.
 
How do run it in discrete by Right clicking? I’m confused I added sea of thieves to the Nvidia control panel to run off the power nvidia processor and it runs the game now but at 30 fps and when I plug the power in WHILE playing my FPS jumps up to 90
Maybe its not giving you that option when in a power saving mode...

I saw a thread that makes a good point, its very likely that even when using your GPU it runs at lower clocks speeds due to your battery not being able to output enough power for the gpu.

Make sure its running in high performance mode when unplugged, and try to poke around for other power settings that could relate to your GPU>
 
Reactions: rjcard32315
Sounds like it might be using the integrated graphics by default when unplugged. You should be able to launch the game using discrete graphics card by right clicking.

Its probably a setting in your power management as well that forces integrated GPU.
 

rjcard32315

Prominent
Jul 29, 2018
76
0
540
1
Sounds like it might be using the integrated graphics by default when unplugged. You should be able to launch the game using discrete graphics card by right clicking.

Its probably a setting in your power management as well that forces integrated GPU.
How do run it in discrete by Right clicking? I’m confused I added sea of thieves to the Nvidia control panel to run off the power nvidia processor and it runs the game now but at 30 fps and when I plug the power in WHILE playing my FPS jumps up to 90
 
How do run it in discrete by Right clicking? I’m confused I added sea of thieves to the Nvidia control panel to run off the power nvidia processor and it runs the game now but at 30 fps and when I plug the power in WHILE playing my FPS jumps up to 90
Maybe its not giving you that option when in a power saving mode...

I saw a thread that makes a good point, its very likely that even when using your GPU it runs at lower clocks speeds due to your battery not being able to output enough power for the gpu.

Make sure its running in high performance mode when unplugged, and try to poke around for other power settings that could relate to your GPU>
 
Reactions: rjcard32315

rjcard32315

Prominent
Jul 29, 2018
76
0
540
1
Maybe its not giving you that option when in a power saving mode...

I saw a thread that makes a good point, its very likely that even when using your GPU it runs at lower clocks speeds due to your battery not being able to output enough power for the gpu.

Make sure its running in high performance mode when unplugged, and try to poke around for other power settings that could relate to your GPU>
I understand now thanks for your help. Yeah my battery is more on the budget side so it has to be my battery just isn’t capable of running the card at its highest usage. I also asked dell and they confirmed that my laptop and most others have to lower the clocks since one the battery is capable and to save power. Thanks again
 

ASK THE COMMUNITY