Question Laptop has "phantom" issue with display ?


Oct 1, 2013
Hello everyone,

Laptop Model: Asus Zephyrus S15 GX502GW

It's been a while since my last post and I'm searching for people with knowledge and experience in solving issues with this specific laptop.
Had a lot of weird situations with PC/laptops which I was able to solve - fix, however this one is really interesting and that is why I need second opinion.

Gonna keep it in chronological order:
1. Battery started having issues showing 250% of charge, then out of charge, acting strangely.
2. After some time display started sometimes to turn on partially, sometimes fully, and sometimes not.
3. Next display started completely turning off, in first millisecond you can see that RoG logo and then it's dark. It's important to note that connecting external displays (I have 2 of those for each port) works just fine. Playing my fav CS:GO without any issues.
4. Updated nVidia drivers, updated Armoury Crate and tried again, still same behavior.
5. Decided to buy new battery, display cable (eDP) which connects motherboard with the display and new display. (240Hz, 3ms, FHD)
6. Swapped new battery and eDP cable, started laptop got dark display again. (I hear the sounds and system is booting)
7. Started in "Safe mode" and since then I can't get display to external monitors either. (probably drivers are not loading for external displays) Also I'm not getting any sound anymore, not even RoG logo animation sound, nor the system is booting only dark screen.
8. Next move I made is replace new display (with new eDP cable connected) and got nothing.
9. Then disconnected new battery and tried old display with new eDP cable still the same.
10. Afterwards attached old eDP cable and tried both new and old displays but with no luck, same issue.

NOTE: Detached BIOS battery couple of times in order to reset it. Need to check voltage.
Also I only have nVidia drivers on it, Intel drivers were not installed because of "Optimus" messing up the experience. Could that be an issue? 🤔

This is my story... Lost time, decent amount of money, energy and still was unable to solve the issue.

The specs sheet:

Asus ROG Zephyrus S GX502GW
Screen15.6 inch, 1920 x 1080 px resolution, IPS, 240 HZ, matte
ProcessorIntel Coffee Lake-R Core i7-9750H, six-core
VideoIntel UHD 630 and Nvidia GeForce RTX 2070 8GB 115W
Memory16 GB DDR4 2666 MHz (16 GB soldered, 1x DIMMs)
Storage512 GB SSD (M.2 80 mm PCIe x2 – Intel 660p SSDPEKNW512G8) + 1 extra M.2 80 mm slot
ConnectivityIntel 9560 AC 2×2 WiFi with Bluetooth 5.0, Realtek RTL8168/8111 Gigabit LAN
Ports3x USB-A 3.1, 1x USB-C gen 2 with DP and charging, HDMI 2.0b, LAN, headphone/mic, Kensington Lock
Battery76 Wh, 230 W power adapter, 65W USB-C adapter included in some regions
Size360 mm or 14.17” (w) x 252 mm or 9.92” (d) x 18.9 mm or .74” (h)
Weight2.04 kg (4.45 lb), .80 kg (1.76 lbs) power brick and cables, EU version
ExtrasRGB backlit keyboard with per-key control, 2x bottom stereo speakers, FHD external webcam


You could have a few different things at play here:
1) You won't be able to use external displays in Safe Mode as it loads very basic VGA drivers to give you a display. (That part was normal.)
2) With the audio starting to give issues and the fact that external displays work fine but the LCD doesn't, you could be dealing with major OS issues that are slowly corrupting over time. It happens. OS reinstall will fix it.
3) With you having replaced the display and cable associated with it and it still not working, it makes me wonder if something is wrong with the LCD connector on the motherboard itself. This sounds like the case even more so because you were getting audio and startup sounds but still a black screen.