Laptop keeps losing wireless network yet other devices are still connected

Status
Not open for further replies.

Thuyme

Reputable
Feb 22, 2014
2
0
4,510
0
I've gone through many forums and found the only thing that would get my laptop reconnected to my wireless network is actually logging in to the modem and restarting it which isn't such a bother but to keep doing it every few days is a hassle. Anyone know why only one device (my laptop) and not my iPhones, iPad and other rarely used laptop specifically chooses to lose the wifi? I run Vista and stream music and movies on my laptop and have tried all the solutions such as update drivers, turn off/on laptop wireless switch, uninstalled the virus programs, uninstall/reinstall drivers, reboot my laptop, ipconfig everything on cmd and changing the channel from 1 to 11. Connecting the cable directly doesn't even help neither does resetting the modem. Ipconfig just results in Media Disconnected in every channel. I actually have to go in and restart the modem for it to work. I can also see everyone's wifi around me as I live in an apartment block but not my own. Why does this keep happening? My partner is becoming annoyed every time I restart the modem! Please help.
 

Ponyface

Honorable
Jan 23, 2013
217
0
10,760
30
ive been in this same situation, i read many forums, tried everything... i had 2 pc's connected with ethernet cables, 3 smart phones, 2 ipads and a smart tv. Had a 30mbps cable connection, we would have to reset the modem at least once per day. Mightily annoying... i changed channels, disconnecting devices not in use, ran ethernet cables to whatever i could and no dice.

I had to break down and buy a better router. This is the best solution, because it definitely works, and just being rid of the hassle is worth the price alone. So id say, just grit your teeth and buy a decent router. eg: http://www.newegg.com/Product/Product.aspx?Item=N82E16833320115

i believe you can even prioritize devices and allocate bandwith where it is needed most, sweet!
 

ALTAiRgr

Reputable
May 13, 2014
2
0
4,510
0
Laptop disconnections from you AP maybe comes due to power settings.
Try this: Tight click on desktop->Personalize->Power Saver->Change Power Settings->(Balanced)Change Plan Settings->Change Advanced Power Settings->WirelessAdapterSettings->PowerSavingMode-> Change both (On Batteries and Plugged In) to Maximum Performance.
 

Damion_2

Reputable
Dec 2, 2015
1
0
4,510
0
For some reason my wife's computer after nearly a year suddenly had "power savings" turned on. She never set it, and it started doing the drop wifi connection after 7 minutes even when plugged in the computer would "shut off" the wifi.

First fix:
Disable it in power management: Slide the mouse down to the bottom-right corner, then once your right-side navigation thing pops up go to the top ‘Search’ (ClassicShell: Press the Windows key In the text box at the bottom) type “Edit power plan” and click the result.

Change advanced settings. Open up the “Wireless Adapter Settings” then “Power Saving Mode” and make sure it doesn’t disconnect your wifi to save power by setting (at least AC, but I went with both because I live life on the edge). Switch it up to Maximum Performance which should stop it from disconnecting at random.

This actually worked on my wifes computer for about 6 days when the wifi would start dropping again even when plugged in. As it turns out there’s another place to control a similar setting.

Second fix:
Go into your network settings. Control panel again.. Mouse to the bottom-right, ‘Search’ again. This time type “Control panel” and click the result. From here we want “Network and Internet” and then “Network and Sharing Center” and from there “Change adapter settings” (It’s on the left hand menubar)

Right click your wifi adapter -> click Properties -> click Configure -> click Power Management

Uncheck the box “Allow the computer to turn off this device to save power”.
 

JMS_9491

Reputable
Dec 9, 2015
1
0
4,510
0
Thank you, Damion_2! My laptop just started this bad behavior yesterday and I was at my wits end - and also convinced that it had something to do with my Windows 10 upgrade that took place last week. I completed both of your fixes and (fingers crossed) it seems to have corrected the issue. Thanks for saving my sanity and a lot of time I don't have on the phone with someone's helpdesk. :)
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS