[SOLVED] Laptop New SSD, can’t access files on old Drive

Jul 28, 2019
2
0
10
0
I got a new SSD (crucial mx500 1tb) to replace my seagate hard drive in my dell Inspiron 15 7000 (7537). I did a fresh install of windows, keeping my old hard drive the same. Windows activation carried over through my windows account and I updated everything on the new SSD and my laptop is running great.

The problem arose when I tried to access my files on my old hard drive. I installed it into a new Sata 2.5 hard drive enclosure and plugged in the usb. I can view a lot of my folders and stuff, but I can’t access the users, and some other stuff, where all my important files are.

For some reason it is not allowing me access, even after going through the prompt which says:
“you dont currently have permission to access this folder. click continue to permanently get access to this folder external drive”

I click continue, and it loads and loads and gets stuck and eventually nothing happens. I tried giving permissions to my user, and then to everyone, but that did not work.
I tried giving my user ownership over the drive, which took like 2 hours, but that still did not work.

I must be doing something wrong, or there must be an easy fix. Please help! Thanks
 

ASK THE COMMUNITY