Question Laptop not using dedicated graphics card

Apr 21, 2019
2
0
10
0
Hello,

I recently bought an MSI laptop in March and ran into the issue with the laptop using integrated graphics instead of the dedicated graphics card, which is a GTX 1060 inside. I initially fixed this issue by going into Nvidia control panel and setting my laptop to use the high performance processor (the GTX 1060 inside) for my applications. This worked up until a few days ago when suddenly I turned on my computer and started up a game and noticed my fps was extremely low and the fans on my laptop were not even blowing. I realized the laptop was using the integrated graphics and not the dedicated one, so I closed the game and proceeded to check Nvidia control panel and the settings still said the game was supposed to be using the 1060 not the intel graphics. I then check all of the games I have installed on my laptop, and ran into the same result. I always have my laptop plugged into the wall when gaming so I don't think thats the issue. I have tried going into device manager as well to disable the integrated graphics, however this did not work as well.

My Nvidia drivers are all up to date and I even uninstalled the drivers and reinstalled them twice.

Windows is updated

Not entirely sure where I should go from this. Any advice would be greatly appreciated.



Thanks




EDIT

After talking to someone in person, they suggested I change my laptops power setting to high performance. This seems to have possibly changed something.
When I loaded up a game to check if anything had changed in my performance, I noticed my GPU was now at 95% usage instead of 0% and the integrated graphics was at 0% instead of 100%, however the fps was still extremely low for the GPU i have inside and the fans for my GPU were still not blowing. I'm wondering what might be a possible solution to this now?


Thanks for any advice.
 
Last edited:

Traditore

Honorable
Nov 5, 2013
549
34
11,190
84
"I change my laptops power setting to high performance". Now your processor is always running at full speed and if you go on battery you won't last long.

Did you specifically assign a GPU to an application?


Also, try setting "Maximum performance" in Nvidia, but in 'Program Settings', not 'Global':
 
Apr 21, 2019
2
0
10
0
Hi Traditore,

Thanks for replying. Sorry I am responding so late.

I have tried this already, and before it worked when I first got the laptop, however now this does not work for my laptop. I'm unsure as to what might have happened between then and now.

I have specifically assigned which applications use which GPU, and set all power settings to maximum performance.

As of two days ago, the result I gained was noticing my dedicated graphics card being used at 95%-100%, however still extremely low FPS and my fan curve was not working.


Thanks for responding
 

ASK THE COMMUNITY

TRENDING THREADS