Question Laptop not working with external monitor

wpeclipse

Reputable
Jul 14, 2017
5
1
4,510
0
So I just bought the BenQ Zowie XL2546K and can't get any video via HDMI. I have updated the graphics. I know the HDMI port on my laptop is used by my AMD ryzen 5000 series processor with its own graphics. The monitor is shown under advanced display settings in windows settings. I can even turn my settings to extend the screens allowing me to move my mouse over and I can actually click on stuff on the black monitor. The monitor is also recognized under audio devices. All throughout this, the monitor says "Cable not Connected". I have also tried using a different HDMI cable and the same problem persists. Seeing as the monitor is I guess being detected but not getting video is puzzling me. Any help would be appreciated.
 

Lutfij

Titan
Moderator
Can you include the make and model of your laptop? An SKU would help us two fold. As for your issue, might want to see this reddit;
https://www.reddit.com/r/BenQ/comments/p0q76y View: https://www.reddit.com/r/BenQ/comments/p0q76y/zowie_xl2546k_shows_no_cable_connected/
Try the method suggested by the OP of that reddit, i.e;
Yes, you should connect your monitor to a display port first in order to activate the menu. once activated, you can switch to HDMI.
Might be a good idea to keep your seller and BenQ in the matter, perhaps you might need to initiate an RMA.
 
Nov 30, 2021
59
15
45
1
Do you have access to another monitor to try it with? Maybe borrow one from a friend?
You eliminated the cable, very well could be a monitor issue, also, have you ever used an external monitor before on this?
 

wpeclipse

Reputable
Jul 14, 2017
5
1
4,510
0
Can you include the make and model of your laptop? An SKU would help us two fold. As for your issue, might want to see this reddit;
https://www.reddit.com/r/BenQ/comments/p0q76y View: https://www.reddit.com/r/BenQ/comments/p0q76y/zowie_xl2546k_shows_no_cable_connected/
Try the method suggested by the OP of that reddit, i.e;


Might be a good idea to keep your seller and BenQ in the matter, perhaps you might need to initiate an RMA.
Laptop is an ASUS ROG Strix G713QM-RS76

Attempted using a display port to HDMI cable and a new error pops up saying "No signal Detected"
 

wpeclipse

Reputable
Jul 14, 2017
5
1
4,510
0
Swap in another known working monitor.

Try the new monitor on another known working computer: laptop and/or desktop.

Key is to determine if the problem remains with the laptop or follows the monitor.
So I plugged in a friend's monitor using my laptop and it works perfectly. Laptops good. Hopefully this is an issue I might be able to work out with BenQ techs and dont have to return it.
 

ASK THE COMMUNITY

TRENDING THREADS