Question Laptop Runs Slow After I Opened it up

Feb 1, 2021
6
0
10
0
One of my laptop fans was making a grinding noise so I opened it up and cleaned the fans. This solved the problem of the noisy fan but now my laptop is running noticeably slower than it was before. When I right click on the desktop it takes almost five minutes for the menu to appear. Total War also runs much slower a takes 4 or 5 times longer to load up. The core temps don't get above 46C and I the CPU power settings are still at 100%. Even so the CPU maximum frequency never gets above 28%. The laptop has two sets of fans and only one ever turns on, but given that CPU temp doesn't seem to be an issue I'm not sure that second set of fans should be running anyway.

Any suggestions about what I can do to speed things back up would be appreciated.
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Make and model of your laptop and it's SKU? You might want to also see what BIOS version you're on at the moment for your laptop's motherboard. Which OS version are you on? We're on version 20H2 for Windows 10.
 
Feb 1, 2021
6
0
10
0
Welcome to the forums, newcomer!

Make and model of your laptop and it's SKU? You might want to also see what BIOS version you're on at the moment for your laptop's motherboard. Which OS version are you on? We're on version 20H2 for Windows 10.
My laptop is an MSI MS-16K2
Not sure about the SKU
BIOS is E16K2IMS.312
OS is windows 10 2004 (Just reinstalled yesterday)
 

ASK THE COMMUNITY