Question Laptop screen not working, replaced cables, replaced screen, external monitor works fine.

Jul 26, 2020
3
0
10
0
I have a Dell Latitude E6540 and the main screen won't work, I have cleaned all connectors, replaced the cable and tried two new screens, external monitor works perfectly which has me confused.

Here is pictures of two brand new screens for this model, both doing different things, the original screen was different also with a pink hue if it was tilted on 99% of angles (It would go away if put on just the right angle)

View: https://imgur.com/a/xNcJzgu
 

Lutfij

Titan
Moderator
tilted on 99% of angles
For the sake of this thread, can you post a video of what angle the screen does display without showing weird things on the screen?

I'm sure that you're subjecting the ribbon cables for the laptop's screen to an absurd angle which might be straining the wires inside to give you the botched display. If I've assumed wrong, then I apologize but the pics seems to make some sense to my assumption.

Also you might want to inspect the area around the cable connections to see if any SMD's or power regulation modules might have fizzled out.
 
Jul 26, 2020
3
0
10
0
Sadly the original screen is now gone, I snapped the connector after twisting it one to many times trying to get the right angle, but those pictures are with brand new ribbon cables and the problem is exactly the same as using the old ones.

Due to it needing to be on a specific angle, twisting the screen and then at one point putting a hard object under where the ribbon cable goes along the hinge putting pressure on it I assumed the same as you, and have come here after the exact same issue with a brand new cable persisted.

Is there anything specific I am looking for to identify fizzled out SMD's/Modules, or will it be quite obvious?
 

ASK THE COMMUNITY