Question Laptop speakers haven't worked properly since I got it...but, halfway through reinstalling them, it works briefly until the installation finishes.

Nootnootpenguin

Commendable
Dec 17, 2016
9
0
1,510
0
Hi guys! I really, really need help.

It was already like this. My bluetooth headphones work but not my plug-in headphones or speakers. They don't at all show up on the audio devices. The work-around is basically reinstalling the realtek audio codec...mid-way through the process it wants to restart, and when it first boots up--gasps. The speakers work.
So, imagine my confusion when the pop-up appears and it wants to finalize the installation, so I do annnnnd...at the very end of the installation, the little sound icon has a red x appear next to it as the speakers disappear again.

If I want to keep them working I basically just don't continue with the 2nd part of the installation, but even then this work-around seems to only work for a day or so.

Rolling back drivers isn't an option--it's grayed out.

Anyway, so that's that. I'm not even sure if the hardware in this case is relevant so just ask if you need it.
 

Nootnootpenguin

Commendable
Dec 17, 2016
9
0
1,510
0
Sorry about taking awhile--gave up hope that anyone would reply. It's such a frustrating issue. Oh, and I tried the reinstall trick but basically a few minutes into everything working the speakers/on-board sound stops working. I can't even webcam a loved one because the headset and audio on my bluetooths (which kinda bypass the issue) keeps cutting off each time immediately when it starts.
 

ASK THE COMMUNITY

TRENDING THREADS