Question Laptop with Nvidia GTX 1650 stopped working ?

Aug 4, 2020
11
1
15
0
Hi all,

I have a laptop acer nitro 5 an515-54, it is i5 9th gen laptop with 1650 4gb.

One day, I had to reset my laptop but after that my laptop GPU is not working and It always shows error 43.

I am not able to open the nvidia control panel it is there in the start menu but when I open it it shows nothing and there is no option of nvidia control panel while right clicking in the windows desktop.

In the device manager it does shows my GPU but it has a yellow triangle and error 43 in it.
but in task manager it only has GPU 0 ( i.e) the intel GPU but not the GPU 1.

In my laptop it has feature called as nitrosense, which lets us control the fan speed and displays the temp and usage, But unfortunately under GPu section it shows only temperature but the usage is always 0%.


Prior to resetting the laptop everything was working nvidia control panel everything. Infact just hours before resetting I had seen the nvidia control panel.

I have tried many things which I saw in internet but nothing worked at all. Here are the list of what all I tried.

1)
Did every possible thing in device manager. Uninstalled the nvidia driver, updated it, tried to rollover to previous version, tried to disable enable, tried updating driver from the device manager manually.
2)
Tried installing the driver from the main nvidia site by downloading it from there then installing it. It shows that the installation is complete but I am not at all able to get the nvidia control panel nor I am able to play games via nvidia GPU and error 43 is still there in device manager display section.
3)
Tried completely uninstall the drivers usind DDU in safe mode several times.
4)
After uninstalling through DDU tried installing through nvidia GeForce experience but it shows no drivers inspite of installing through it repeatedly. Also error 43 still present in device manager.
5)
Complete reinstall of windows.
6)
Downgraded the laptop BIOS but still nothing improved.
7)
Installed the acer recommended drivers still the problem faced as mentioned in point (2).
8)
Tried doing all stuffs in services. Nothing improved.
9)
Battery reset
10)
Installed Ubuntu, there also when I try to install drivers of GPU it installs successfully but after I restart it goes to login page and login password loop begins.
11)
Tried installing different versions of windows 10.

If anyone can help I will be grateful as I had spent majority of my savings to buy this laptop.
Also the warranty is also over and there is complete lockdown in our place so I am in total fix.
 
Last edited:

Eximo

Titan
Ambassador
Very thorough. I think you can conclude the GPU has failed in some manner.

You can try taking the laptop apart and reassembling it, just to see if that makes a difference. But it doesn't seem like it is showing any signs of life.

Getting the same effective result in Linux certainly rules out a software problem.
 
Aug 4, 2020
11
1
15
0
Very thorough. I think you can conclude the GPU has failed in some manner.

You can try taking the laptop apart and reassembling it, just to see if that makes a difference. But it doesn't seem like it is showing any signs of life.

Getting the same effective result in Linux certainly rules out a software problem.
Yes, I had the same thought.
Even GPU-Z is not showing the bios version it is just showing unknown.
So I think I will have to use it without GPU :'(
 

ASK THE COMMUNITY

TRENDING THREADS