Question LED lights on and fans not working... how do I fix this?

Aug 9, 2019
9
0
10
0
So i just built a new PC, and everything works fine - seemingly. In fact, I'm writing this message using my PC right now.

However, there is a red LED light that is lit on my motherboard right above the graphics card, as well as a white light. None of my fans work, and the case lights won't turn on either.

I'm basically reaching out because I'm afraid that something is wrong, but my computer is just working through it, and that I'm going to have major problems in the future.

I have asked around plenty and no one seems to have any knowledge on the subject.

Any and all help is greatly appreciated.

Here are my specs:

Operating System
Windows 10 Education 64-bit

CPU
Intel Core i5 @ 2.80GHz 43 °C
Coffee Lake 14nm Technology

RAM
16.0GB Dual-Channel Unknown @ 1064MHz (15-15-15-36)

Motherboard
Micro-Star International Co. Ltd. H310M GAMING ARCTIC (MS-7B28) (U3E1) 43 °C

Graphics
VX238 (1920x1080@60Hz)
4095MB NVIDIA GeForce GTX 1050 Ti (Gigabyte) 50 °C

Storage
465GB Samsung SSD 860 EVO 500GB (SATA (SSD)) 35 °C
 

jon96789

Upstanding
Aug 17, 2019
284
35
240
7
What kind of fans are they? The fans (if they have no LEDs) should be connected to the SYSFAN connectors on the motherboard. If they do have RGB LEDs, they should have an additional hub to connect them to and the hub is connected to a internal USB connector.
 
Aug 9, 2019
9
0
10
0
and you haven't checked the bios menu to check if they're just disabled ?
Okay so I did that, and there didn't seem to be any problems.

But I kind of want my case lights and case fan to work... Although im not skilled enough to troubleshoot myself. Any suggestions on where to begin?
 
Aug 9, 2019
9
0
10
0
What kind of fans are they? The fans (if they have no LEDs) should be connected to the SYSFAN connectors on the motherboard. If they do have RGB LEDs, they should have an additional hub to connect them to and the hub is connected to a internal USB connector.

everything is connected as you said. it is a pre installed fan in the case. I really have no idea. I downloaded all necessary drivers and still nothing - the case fan does not work, no RGB LED lights on, and the white and red troubleshoot lights above my GPU is still on. REALLY need help.
 

ASK THE COMMUNITY