Question Lenovo AIO boots straight into UEFI Setup/ BIOS ?


Feb 28, 2012
My brother has a Lenovo F0EY00F5AU AIO
512GB Micron M.2 SSD

2 days ago it stopped booting in to Windows and went straight into Setup/BIOS.

He brought it round and it worked absolutely fine at my place, I updated BIOS, scanned SSD with Macorit HDD checker - all good and installed some minor windows updates.
Worked fine for me apart from a few times it took ages to shutdown and it wasnt installing updates.

He takes it back home and straightaway its going into setup and not booting into Windows again.
He sent me some pics of the setup screen and the SSD is still detected so why is it not booting into Windows?
I am suspecting HW, either the SSD or mobo, there is a spare SATA port so I can try a SATA SSD if necessary but thought I would ask for any ideas before I start taking it all apart.



Did you check the time for the AIO while you were in BIOS? It's possible that the CMOS battery for the AIO might be having an issue then again if the wiring in your brothers crib is suffering from a grounding issue, you could also see something similar, whereby the AIO won't boot up or the drive is missing from the BIOS.

On the other hand, it could very well be the OS acting up, being corrupt. I'd have reinstalled the OS to put a nail in the coffin. Yes sometimes a BIOS update or an OS update is all you need but a failing SSD can also show up in BIOS, and have a corrupt OS on it, preventing boot to GUI.

Reinstall the OS, after fabricating an bootable USB installer for the OS, and see if the install holds up. If not, then the SSD might be at fault here.