Question Lenovo AIO - - - No splash screen, no BIOS, no Windows, just blank screen

Feb 26, 2020
1
0
10
0
Hey gyus, I could use a little help
For the past 2 days I've been troubleshooting this older Lenovo AIO.
The thing is it ,,died" in April. It has been taken to the repair shop but they didn't give it very optimistic chances to work again.
Day 1:
,I managed to turn it on. First, the power switch and the screen Led lit up. That was it. The screen was black, no hard drive led
Then I found a way to power it up:
  1. Plug the power cord out
  2. Hold the power button for couple of seconds
  3. Plug the cord in
  4. Hold the power button for couple of seconds
  5. Release the power button and wait
However, this way I can't see any boot image (lenovo logo). After a while it jumps strait to Windows loading
When trying to turn it on different way, it is just black screen even without the hard drive led. When I press F12 for example (boot menu) I can hear a beep but nothing happens, just black screen. Similar for bios, this time without the beep
I tried to access the bios via Windows (recovery environment or how is it called), but the result was the same. I can't factory reset it as well. Everything in the Windows works OK, the hard drive isn't corrupted. The only problem is that the resolution is stuck at 1024x768 for some reason (I've used it at Full HD before)
I tried booting it both with and without hard drive, changed the Ram slot, changed the CMOS battery, tried reseting it (no jumper, so I connected 2 pins, hopefully correctly). After changing the battery and turning the system on, I could hear 2 short beeps, which stands for Parity error, the first 64KB memory chip encounters parity failure. In CMOS settings, set memory ECC check to "DISABLED" and the problem is resolved. However, it is better to replace the memory. I updated all the drivers and even ran CMOS de-animator to clear the memory, but with no success. Also I disabled fast startup.

Day 2:
Sill bootable, same as day one
Updated all drivers using driver booster 7. I also updated the graphics driver hoping to fix the stucked resolution. I completed the installation via driver install app, then a windows notification appeared that it needs restart. Restarted it, but it took way to long to boot and since it was an hour left to midnight, I unplugged the power cord and went to bed (maybe that wasn't the smartest decision)

Day 3, today:
I tried powering it the ol' reliable way, but this time it didn't boot to Windows, and I waited for quite a long time. The screen stayed blank. The fans are spinning and I can still hear the HDD spinning. All indicators are lit. Tried booting it several times without the CMOS battery, but with no luck. BIOS and boot menu still inaccessible. Created a USB boot drive but that brought no success.

Components
Intel Pentium g2030
4gb ram ddr3 one stick
500 GB hdd
Geforce 615 (that's what the computer says)
 

maikutech

Distinguished
Nov 1, 2012
1,304
8
19,965
286
Well if you can carefully take part the aio lenovo and rebuild it, you will need a replacement mobo.
Two short beeps from ibm/lenovo machines indicate a ram problem.
Give me the exact model number for that aio lenovo, then I will see about finding a replacement mobo with ram.
 

ASK THE COMMUNITY

TRENDING THREADS