Question Lenovo IdeaPad 300 - - - no display, fan not working, immediately shuts off ?

Jun 25, 2022
2
0
10
0
Good day. My apologies for my grammar. English isn't my native language. I have a problem with the Lenovo IdeaPad 300. It won't boot anymore after cleaning it and changing the thermal paste. The fan doesn't spin. It will immediately turn off within 3-5 seconds. I tried reseating the RAM and testing it with two of my RAM sticks., but it still doesn't work. I've also tried resetting the CMOS battery by removing it for about 10 minutes. I've also removed the battery from the connector and held the power button for about 30 seconds. Still the same. What's the issue with my laptop? I can't afford to buy another laptop right now. I also bought it three and a half years ago.

Much appreciated for the answer.
 
Last edited:

Cyberat_88

Distinguished
Apr 9, 2011
1,774
35
19,890
48
Tested the CMOS battery ? Or just buy a new one anyways after 4 years almost.
Use silver thermal paste, especially for laptops.
When you reset CMOS put back all the Ram you plan on using as the Bios needs to configure it, if compatible.
 
Jun 25, 2022
2
0
10
0
Tested the CMOS battery ? Or just buy a new one anyways after 4 years almost.
Use silver thermal paste, especially for laptops.
When you reset CMOS put back all the Ram you plan on using as the Bios needs to configure it, if compatible.
Hello, thank you for responding. My laptop is now working perfectly fine after 3-5 days. I forgot to mention that I accidentally spilled 70% isopropyl alcohol on the CPU and GPU while I was cleaning it. It's just really weird that my laptop is now working perfectly well. I've been using it for a week. No issues so far.
 

ASK THE COMMUNITY