Question Lenovo laptop not accepting new DDR3 RAM modules ?

Aug 30, 2021
My Lenovo G50-80 laptop (i3 5005u with R5 M330 2GB model) had 2X4GB RAM modules ("SAMSUNG M471B5173EB0-YK0 DDR3 4 GB" and "Hynix HMT351S6EFR8C-PB DDR3 4 GB"), both worked fine and CPUz was showing 1600MHz and 8GB total. The Hynix RAM was purchased in April.
I had to remove the Hynix 4GB module so that I can sell another old laptop with extra RAM. The Samsung module was not working in the older laptop (which I sold).

So my Lenovo G50-80 now only have 4GB RAM (Samsung) and I bought 3x4GB RAMs online and none of them are working! Yes the OS is 64 bit. laptop is not booting with new RAM modules.
Even tried same Hynix HMT351S6EFR8C-PB DDR3 4 GB from the same seller (I previously purchased in April and it was working) and it was also not working. Also tried the same RAM from a different seller, it didn't work either.

Today I tried SAMSUNG M471B5273DH0-YK0 - DDR3L (actually I ordered SAMSUNG M471B5173EB0-YK0 but the seller shipped different)

I tried swapping slots, tried to booth only with the new RAM and none of the methods works.
Even updated the Laptop BIOS to latest available version.

The laptop is not accepting any new RAM it only works with the RAM it came with, which is an old 4GB SAMSUNG M471B5173EB0-YK0.
What could be wrong ?
Is it a motherboard complaint ?
Should I try 8GB module ? but even 4GB module is not working...

Working RAM, came with laptop.


Hynix worked earlier, but newly tried 2 modules (same model number) didn't work. I don't have access to the old Hynix RAM anymore.
Last edited: