Question Lenovo M83 MT - blank screen with blinking cursor?

Jul 20, 2020
3
0
10
0
Hello,

I have a strange problem with my Lenovo M83 MT. I make upgrade of some components -

32GB Ram;
i5 4460,
NVidia GTX 750 ti
Thermaltake 600W.

When start the computer only what i can see is a blank screen with blinking cursor. If I use integrated video on motherboard everything works just fine. (Windows 10 64-bits) but I have to unplug NVidia card for that so Windows doesn't see it.

I'm pretty sure Videocard works fine (I test it on another PC and works with no problems)

I tried and with another Videocard NVidia GTX 550 ti and also no luck same blank screen with blinking cursor.

I update BIOS with lastest version from Lenovo support page

Also I already reset CMOS with jumper

I already tried different option in BIOS for video - PEG, PCI and AUTO but also with no success

MOBO have two PCI-e slots. I tested several times any.

Could you help me please. Any suggestion?
 

Lutfij

Titan
Moderator
Thermaltake have a huge range of PSU's, from horrible units to somewhat reliable units, which one do you have? I mean what is the model for your Thermaltake PSU? Have you tried powering down the system, disconnecting from the wall and removing the CMOS battery for at least 30 mins before replacing it? Also, you should use DDU to uninstall your GPU drivers(while in Windows) before you drop the latter GPU in.

FYI, the GTX550Ti and GTX750Ti both have different power draws. How old is the PSU?
 
Jul 20, 2020
3
0
10
0
PSU model is: Thermaltake LT-600AL2NL. I know it is old but same PSU worked very well with same GTX 750 ti (Asus) on another motherboard (Asus H81M).
I just transfer my CPU, GPU and SSD (for the protocol old PC was with 16GB Ram) to Lenovo with 32GB Ram. The main difference is 16GB ram power comsuption.
Lenovo has that specs (if that helps):
Type and model - 10AGS03400
Serial Number - S4G53067
BIOS Revision level - FBKTDEAUS - 06/16/2020
Embedded Controller Version - FBCT13A
ME Firmware Version - 9.1.45.3000


Now I will try your advice i hope will works
 

ASK THE COMMUNITY