Question Lenovo Thinkcentre M93: two beeps after changing from Legacy to UEFI, no display and no POST ?

Jan 31, 2023
Some days ago a friend of mine gave me his Lenovo Thinkcentre M93 to fix something related to drivers, screen resolution and told me someone changed something in the BIOS. PC would boot until I entered the BIOS and without thinking I changed boot options from Legacy to UEFI. After saving and exiting the PC wouldn't boot and after some seconds it made two short beeps. I tried:

  • Removing the CMOS battery for five minutes (also tried putting it upside down),
  • Clearing the CMOS putting a jumper in the right place,
  • Removing all ram sticks (which caused the PC to beep differently),
  • Removing some ram sticks and leaving some, changing their positions,
  • Disconnecting the HDDs
  • Tried to remove the GPU but I applied too much force and broke the clip

I don't know what else to do. I read that two beeps means ram or board failure, but since it's a Lenovo PC I don't think that any other motherboard would fit in the case and neither my friend or I have any money to buy new components. Mistakes I made were:

  • Removing the CMOS battery and other components without an antistatic wristband so I think I could have have fried something with ESD.
  • Not disconnecting the AC power cable from the PSU which doesn't have a switch, so the PC turned on instantly when connecting it to the power outlet.

People on Reddit told me to get and try other RAMs with I got today. What can I do? Sry if bad English.