Lenovo y510p Laptop Ultrabay graphics card loud noise

222lu222

Honorable
Jun 19, 2013
140
0
10,680
0
Hey guys, I have a Lenovo y510p and my ultrabay graphics card is making a loud noise whenever it is activated. This issue has been on and off for almost a year now but it eventually goes away. However it has been 2 days and it has not stopped. The noise is quite loud and annoying. I removed the Ultrabay GPU to see if it was maybe dust or something, but the noise sounds even when i would manually spin the fan. It is much lower however and I assume that when the fan starts spinning faster is what makes the noise so loud. Do you guys know of any way I can solve this problem? Any help is greatly appreciated! Thank you for your time
 
"Do you guys know of any way I can solve this problem?"
Replace the fan

Pretty much all parts in a laptop are replaceable including the fans.
But... In general you should leave that kind of repair to experts like myself.
Do you happen to live in Minnesota (USA)?
 

222lu222

Honorable
Jun 19, 2013
140
0
10,680
0


Hmm I didn't realize that replacing the fan on the Ultrabay graphics card was an option... Sadly No I don't live in Minnesota. But thanks for the idea.
 


I looked at this "Ultra Bay graphics card" you refereed to and didn't realize what it was. I expected that the graphics card was cooled using a typical heat pipe solution and fans, instead it looks like Lenovo went down the proprietary road with that solution... which is bad news for you. You might not be able to replace the fan in that device (you can certainly try). But that is not a typical laptop fan that is easily replaced by technician.
I would call Lenovo or just live with it. Alternatively you could buy a replacement one on eBay but they look overpriced for what you get.
 

ASK THE COMMUNITY

TRENDING THREADS