Question Lenovo Y720 SSD M.2 Issue...

PabloLeon

Commendable
Mar 5, 2017
3
0
1,510
0
Lenovo Y720 Issue with an SSD M.2 WD

Hi guys, hope you can help me.

i had an intention of increasing my storage and speed up my pc, and i wanted to use my M.2 port so i bought an SSD M.2 Drive exactly this one:
Western Digital Blue 3D NAND SATA SSD 500GB 500GB M.2 M.2 - Disco duro sólido (500 GB, M.2, M.2, 560 MB/s, 6 Gbit/s), and i did mounted but it doesen't appear on my disk manager, or the BIOS.

My laptop is Legion Y720-15IKB.

Thanks!
 

Lutfij

Titan
Moderator
First make sure you're on the latest BIOS update for your laptop. Second, can you parse on a link to your SSD purchase? Third, what do you currently have the OS on? From the looks of it, via web search, you can drop in an NVMe drive in the M.2 slot.
 

PabloLeon

Commendable
Mar 5, 2017
3
0
1,510
0
First make sure you're on the latest BIOS update for your laptop. Second, can you parse on a link to your SSD purchase? Third, what do you currently have the OS on? From the looks of it, via web search, you can drop in an NVMe drive in the M.2 slot.
Thanks, Lutfij.
I've the lastest version of the BIOS, and im using Windows 10 Home Single Edition, and here is the link...
https://www.amazon.com.mx/gp/product/B073SBX6TY/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1

i also found this other one, and im thinking on do a return and buy this:
https://www.amazon.com.mx/Crucial-Interno-Unidad-Disco-óptico/dp/B07J2WBKXF/ref=sr_1_fkmrnull_1?__mk_es_MX=ÅMÅŽÕÑ&crid=2B72XEOJ3KVKO&keywords=crucial+p1+500gb+3d+nand+nvme+pcie+m.2+ssd&qid=1556171296&s=gateway&sprefix=Crucial+P1+500gb,aps,344&sr=8-1-fkmrnull
 

ASK THE COMMUNITY

TRENDING THREADS