Question Lian Li Galahad 360 not cooling anymore

evilrid1

Honorable
Feb 7, 2017
18
0
10,510
0
Hello
back in june i experienced a problem wtih my aio getting high idle temps on my cpu and i made a post back then explaining my problem, now 3 months later im having the same problem, my aio not cooling the cpu and making weird grinding noise and this time it feels like the pump is not working at all, my radiator is cold and the temp is going over 100° C degrees and eventually it will shutdown.

I tried to reapply thermal paste again but it is the same. Now i have read many cases like mine and i dont like to think that this is really faulty and bad quality aio made by lian li... yet .

Idk what i can try more to exclude that its not the pump but im all open for suggestions, so thanks in advance for any help!


My specs:
CPU: AMD Ryzen 5600x
MB: Gigabyte B550 AORUS PRO v2
GPU: ASUS TUF RTX 3070 Ti
RAM: GSkill 32GB
CPU Cooling: Galahad AIO UNI FAN SL 360
Case: Lian Li o11 dynamic
 

evilrid1

Honorable
Feb 7, 2017
18
0
10,510
0
Aside from the advice in that thread to try an air cooler, you may want to buy a new AIO.
Yeah, the thing is im out of thermal paste so i cant try with air cooler, i have to see tomorrow what ill do, just now i have found more and more posts about the same problem with this specific aio and it seems like its really bad quality product, few people got replacement from lian li but they failed also after using it for 6-12 months.
 
Nov 22, 2022
1
0
10
0
I also experienced high idle temps, though not as bad as 100 degrees C. I discovered that the L-Connect software was making my CPU run around 50 degrees idle. As soon as I stopped it through task manager my CPU temp dropped to the 30's. It doesn't need to stay running for your LED's to work.
 

ASK THE COMMUNITY