• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

[SOLVED] lightning just struck near me

extraproblems

Honorable
May 18, 2014
43
0
10,540
1
it's not storming yet, however lightning just struck near me and it sounded like it was right on me. I was in game at the time, and the game froze and I lost connection. however, my modem never lost signal. I called my parents down the street and their cable internet went out then came back on. my pc still works fine but no internet. there is no light near ethernet port. I have tried 2 cables. keyboard, mouse, headphones all work. I just built this pc in March.. did only the ethernet port fry and everything else works fine? is this possible? never experienced anything like this, I'm hoping someone can shed some light for me
 
Jun 24, 2020
27
5
45
2
I would say your modem is probably the culprit if you have installed a new network card.

The green light is just the indication that the modem "sees" the connection. If the transmit/receive circuit is damaged, it makes no difference if the light works...
 

extraproblems

Honorable
May 18, 2014
43
0
10,540
1
yes the modem is working, it never went out. I even unplugged and reset modem and it's connected. I ran network trouble shoot and it's telling me to plug in ethernet cable. and it is plugged in. is it possible even though it's lit up properly the cable could still be out? I guess I should call isp?
 

extraproblems

Honorable
May 18, 2014
43
0
10,540
1
well I just called isp. everything is working fine on their end and modem is connected. but I've tried all the cables I have, none of them are working. I am stumped
 

extraproblems

Honorable
May 18, 2014
43
0
10,540
1
is it possible only the ethernet port fried? I guess I should get a network card and test. just want to know if this is a likely possibility that this is what happened. if this is the case I'm thankful the whole mobo didn't fry
 

USAFRet

Titan
Moderator
Mar 16, 2013
126,056
4,409
159,940
19,752
is it possible only the ethernet port fried? I guess I should get a network card and test. just want to know if this is a likely possibility that this is what happened. if this is the case I'm thankful the whole mobo didn't fry
Possible?
Absolutely. I had exactly that happen a week ago.

On the PC, just the ethernet port got fried. Also, the ethernet port on the printer.
A few other things around the house, but on the PC and printer...just the port.

A new $10 NIC, back in business.
 

extraproblems

Honorable
May 18, 2014
43
0
10,540
1
I installed the network card and all lights are working. but I'm getting a "ethernet 3 doesn't have a valid ip configuration" error during the trouble shoot. I have reset the modem, but still no luck. not very good with networking, do I need to contact my isp? my nic did come with drivers buts a mini disc
 

extraproblems

Honorable
May 18, 2014
43
0
10,540
1
well I was able to use the CD to install drivers but it's still not working. when I run the trouble shoot, it's telling me to plug a cable back in again, plus the ethernet 3 doesn't have a valid ip confif. but I'm getting a green light on the nic and the modem is lit up properly and online
 

extraproblems

Honorable
May 18, 2014
43
0
10,540
1
could it be my modem? everything lights up properly and my isp says it's connected. after installing drivers, now when I run troubleshoot, the light on nic cuts off and I'm getting plug ethernet cord in. then after trouble shoot the light comes back on. I did the flushdns & netsh reset commands. I don't know what else to do
 

extraproblems

Honorable
May 18, 2014
43
0
10,540
1
yes I tried that. I have a wired modem, no router. all my modem lights are normal. is it possible it's modem even though its lit up correctly and my isp says I'm online
 
Jun 24, 2020
27
5
45
2
Yes, a chip can be blown in driver circuit of the ethernet. The modem will appear to work, but no transmission will occur.

All ports are dead? Usually there's more than one...
 

extraproblems

Honorable
May 18, 2014
43
0
10,540
1
the one I have only has 1 port. so I'm wondering if this is a modem issue? again, my pc is working just fine. it's just my ethernet port and now issues with this nic, even though it lights up
 
Jun 24, 2020
27
5
45
2
I would say your modem is probably the culprit if you have installed a new network card.

The green light is just the indication that the modem "sees" the connection. If the transmit/receive circuit is damaged, it makes no difference if the light works...
 

extraproblems

Honorable
May 18, 2014
43
0
10,540
1
that's crazy if that's the case. and if I go buy a new one I will have to contact my isp to setup the Mac address I suppose. maybe that's what I will try next. have you heard of a modem lighting up properly and your isp saying I'm online but it doesnt "work"?
 
Jun 24, 2020
27
5
45
2
IF it is that only the ethernet transmission chipset is damaged within the modem, the modem will still appear to function normally to the ISP becasue it can see and communicate with the modem, but you cannot because you cannot communicate with the modem.

If you know anyone with a laptop, have them try using it on your modem. Should tell you pretty quickly if it is working...
 

extraproblems

Honorable
May 18, 2014
43
0
10,540
1
UPDATE: the ethernet port did get fried and also the modem was messed up even though the lights showed it was working. I bought a new modem and did in fact need the NIC to connect. I'm back in business, thanks for the help, Kinora
 

ASK THE COMMUNITY

TRENDING THREADS