Linksys E3000 wired issue


Dec 8, 2011
Hey guys,

I have a head scratcher thats driving me crazy. I have a connection that is capable of speeds of 20-25mbps. I have the above router installed on my system. Most of my wireless devices average 19mbps when connected wireless via router. However, my "main" computer is wired via router is only 4mbps consistently(25mbps when connected directly to the modem). When I connect another computer to the wired connection that computer gets 20mbps easy. I am led to believe that there is a setting or something that is not set correctly between my router and main computer because when the two are wired, my router still reads that is is receiving the 25mb but i am only receiving a 4mb output. Something is happening between my router and NIC, and my NIC cant be faulty because i can get 25mbps when wired directly to the modem. I dont know where to go from there a setting I should be looking at? Duplexes maybe? Help if you can! Thank you in advance! :pt1cable:

-I am using the built in NIC on a Asrock fata1ly z68 pro gen 3 mobo
-the router is properly cooled
-firmware is up to date
-have tried open source firmware
-wired connections are tight and have tried multiple cables
-not an ISP issue.


Try disabling ipv6 on the router, reboot the router and see if things are any better.

If you don't have to many options configured in your router you may want to try resetting it to defaults if the ipv6 option doesn't help. I'm not certain what option may be setup to be causing the issue, but resetting things to defaults may help.

Seems like you've already done most other troubleshooting.