Question Linksys EA7300 can't log into firmware.

stchman

Distinguished
Oct 7, 2012
87
0
18,630
0
Hello all. I have a Linksys EA7300 router. I cannot get into the firmware unless I do a hard reset. If I try to log into the router it just spins for a LONG time and them goes back to the login screen.

I have seen that some other folks out there are having the same difficulty, but there appears to not be a workable solution.

I have a .bin file that I created that is a backup of the firmware settings so I can get back up and running.

Does anyone on the forum know a fix for this problem?

Thanks.
 

COLGeek

Cybernaut
Moderator
Are you using a Linksys firmware or a 3rd party firmware?

Have you performed a hard reset of the router and then updating to the most current firmware available for your device?

Are you attempting to connect via a wired or wireless interface?

Last, do you have the Linksys app on a smartphone and have you tried using it to access the router?
 

stchman

Distinguished
Oct 7, 2012
87
0
18,630
0
Are you using a Linksys firmware or a 3rd party firmware?

Have you performed a hard reset of the router and then updating to the most current firmware available for your device?

Are you attempting to connect via a wired or wireless interface?

Last, do you have the Linksys app on a smartphone and have you tried using it to access the router?
Stock firmware.

Twice doing a factory reset on router, I have the latest firmware.

The app on my phone is really spotty to access the router.

I log into the router via the 192.168.1.1.

After FINALLY speaking with tech support at Linksys it turns out that you HAVE to create a Linksys Smart Wi-Fi account. After doing that you need to then connect the router to your account.

At least the good thing is that you can disable remote access in the router firmware.
 

ASK THE COMMUNITY