Question Linux and USB3 ports

May 25, 2019
9
0
10
0
I have two usb flash drives:
  1. Apacer USB 3.1 Gen 1 64GB
  2. Toshiba USB 2.0 64GB
Devices used:
A Medion PC (used usb 2 ports and Vbox)
My MSI Laptop (has 3 usb 3.0 ports,also used for booting the Apacer flash drive and Toshiba to use linux)

I bought the Apacer flash drive 2 days ago to install Ubuntu since the Toshiba one is too slow.
When i installed ubuntu on the Apacer flash drive i noticed it had around the same speeds of booting and operations as the Toshiba flash drive
So I checked on the Live CD what is going on with lsusb
I found out that the Apacer flash drive uses the 1.1 or 2.0 root hub while my Toshiba flash drive always uses the 3.0 one (both plugged on the USB 3 port, of course
I thought Ubuntu was the problem so I tried other linuxes and it was the same

Here are the linuxes that I tried with same results
MX Linux 18.3 (both x32 and x64 , Live CD and installed)
Lubuntu 16.04 (both x32 and x64 , installed only)
Ubuntu 16.04 GamePack (x64 only , installed only)
Ubuntu 18.04 (both x32 and x64 , Live CD and installed)
 

ASK THE COMMUNITY

TRENDING THREADS