Question Linux Mandrake 7.0 in VirtualBox - can't change screen resolution

Mar 2, 2019
1
0
10
0
I'm trying to set up a KDE 1.x VM, and I was able to get it up and running with Mandrake 7.0, but I'm running into this problem where I'm stuck at 640x480 resolution no matter what I do. If I try to change the screen resolution in DrakConf using the "change X resolution" button, nothing happens, and if I go through the graphics configuration process, selecting "generic VGA compatible" as my graphics card and then choosing a 1024x768 video mode and then trying to adjust the resolution, it gives me an error that says "No valid modes found. Try changing some parameters." I've tried running the VirtualBox guest additions installer and changing the VirtualBox graphics adapter and the amount of video memory, as well as tinkering with everything I could think of in the guest, but nothing seems to work. I'm running VirtualBox under Windows 10.

Does anyone know of a solution to this, or alternatively, an easier way to get KDE 1 running in VirtualBox?

EDIT: I just tried installing Red Hat 7.0 and ran into essentially the same problem during the graphics test phase. I'm thinking this is an overarching problem with VirtualBox and old Linux versions.
 
Last edited:

Satan-IR

Honorable
Apr 18, 2014
839
38
11,390
136
I think the latest version of Virtual Box is 6.0.6. I have used 6.0.4 and have installed Guest Additions easily in Ubuntu, Debian and Open SUSE guests on it.

If you want to work with Linux you can try other distros if you have no luck with Mandriva/Mandrake and do not insist on using that as it is discontinued. There are lots of guides online on how to setup Guest Additions on Ubuntu, Open SUSE, Debian etc. You can get KDE on them too.
 

ASK THE COMMUNITY

TRENDING THREADS