Question Linux no boot

I have a ACER Aspire one and am trying to boot some form of linux.

First i installed android x86 from usb and it worked normally but i found my wifi adapter isn't Android compatable.

So then i booted into a lubuntu live cd. Installed, shut down, removed usb, and recieved "no bootable device found".

Booted back into the lubuntu live cd and reinstalled. Still no boot after installation.

Then i booted into a popos live cd and installed. Shut down, removed usb, and recieved the same error upon boot.

Then i booted into a ubuntu live cd. I tried to install 2 times and still received an error and could not boot.

I have tried csm and uefi modes aswell as clearing cmos with no progress.

Below are the options i have below in my bios and my system specs. I want to know how to get it to boot.

Intel Celeron N3060 dual core
2gb ram
32gb emmc
I am installing os from a PNY 128gb USB3.0 drive.

https://ibb.co/cLs1zZP
https://ibb.co/f81Q74h

Sry about the blurryness. Anything grey cannot be edited.

This laptop came with w10 and I have ran lubuntu on this laptop before, but now no linux will boot after install.
 

dmroeder

Distinguished
Jan 15, 2005
1,307
6
19,465
55
I've ran into similar situations with Ubuntu as well, I believe what is happening is that GRUB (boot loader) is failing to install during the install process. Not sure why but try following the reply below:

https://askubuntu.com/questions/145241/how-do-i-run-update-grub-from-a-livecd

The 30,000 foot view of what is happening in that post is after the install, boot back into the live CD session, mount the partitions from your hard drive where the install is at, run some commands to install/update GRUB. This has worked for me the couple of times that this happened. Hope it helps!
 
Reactions: NightHawkRMX
I found the issue. The os installed properly, however, the stupid bios has no clue what to boot from.

You have to go and select the .efi file for secure boot. Secure boot must be enabled as the bios doent allow you to turn it off.
 
And once i figured out the no bootable found issue, the system tries to boot.

However it gives me this error: "end kernal panic - not syncing ufs unable to mount root fs on unknown block (0,0)"

Which probably is an grub issue from reading.

Ill try the steps above. Why oh why cannot linux just install properly now, even though it did a few months ago.
 
I figured it out with some help over at the Linux forum.

First, the cause for the "no bootable device" was secure boot not knowing what file to boot from.
Rufus needs to be in GPT UEFI mode when creating the bootable installation disk, otherwise the machine cannot boot from the installation.

I recreated the live CD with Rufus set to GPT and UEFI and then installed Linux from this USB. Then rebooted and selected grub.efi to secure boot from. Boom, Linux, working as it should!!
 
Yep. I had a hard time getting the laptop to output the audio via HDMI, bit I figured it out.

The laptop is pathetically slow, but HD youtube is mostly feasible and I can stream games from my good PC to my tv in my living room over wifi now.
 

dmroeder

Distinguished
Jan 15, 2005
1,307
6
19,465
55
Ah, I just went back and looked at your OP, it looks like it may have been a chromebook or something?

At this point you probably don't want to mess with it but maybe Lubuntu or Xubuntu may perform a little better than Ubuntu. If you have the space available, you may be able to install the desktop environments from them (LXDE/XFCE) and see if it performs better. I've never actually tested the difference between a fresh install of Xubuntu vs installing XFCE in Ubuntu.
 

ASK THE COMMUNITY

TRENDING THREADS