Question Logitech C270 Webcam and Teams

Dec 4, 2020
14
3
15
0
Hey folks

Happy New Year to all

I have recently added the above webcam to my system, and I am having issues with it transmitting my image in black and white and poor quality when using within MS Teams.

Webcam - Logitech C270 HD
Graphics - Gforce 1050 ti
OS - Win 10 64bit (fully up to date)

It appears to relate solely to Teams transmissions.

A google search as demonstrated that I am not alone!

When I query the driver install in "device manager", I notice that the device is listed as "USB Video Device" and the driver indicated is a MSoft one.

I have downloaded the Webcam setup software which is the only software that I can see on the Logitech website, and there are no specific "drivers" other than the Dlls wihtin the installed subfolder. I have asked Windows to update the driver with no success and even pointing it to the installation folder it insists that the MS drivers are best.

Help?

Is the above correct?

Any input appreciated.

James
 

Lutfij

Titan
Moderator
You're on Windows 10 version 20H2? If so, turn your attention to the chipset drivers, see if reinstalling them changes your experience. Did you also install the software meant for their webcam which can be found here...? Install the app/driver package in an elevated command, i.e, Right click installer>Run as Administrator.
 
Dec 4, 2020
14
3
15
0
hi there

thanks for the response!

as an update, I found am optional update under windows update that included the Logitech driver so that appears to have at least resolved the camera driver as it is now listed as the correct device under the manager.

however the image does occasionally still flicker to black and white (albeit only with teams still)

the image quality is pretty crappy too it hey ho.

I did reinstall the software as admin but his didn’t appear to make any material difference.
I will take a look at the chipset as you suggest and report back!

thanks

james
 

ASK THE COMMUNITY

TRENDING THREADS