Question Logitech C920 Stopped Working

Nov 23, 2020
1
0
10
0
First time poster here.

Start with specs of computer I suppose:
CPU: i7 8700k
MOBO: Aorus Z370 Gaming 5
RAM: G.skill trident z rgb 3200mhz 32gb
GPU: MSI Seahawk 1080ti
PSU: EVGA G3 650W

I went on vacation over the weekend and came back trying to stream some more and low and behold my webcam is no longer working. My computer was turned off the entirety of the weekend I was gone. I have uninstalled the device from device manager numerous times. Restarted computer, tried different USB ports and a laptop. At first nothing was coming up on my desktop, but on my laptop is popped up in unspecified in control panel with a descriptor error. After trying several solutions I've found online its now recognized on my desktop as what it should be, "Logitech HD Pro Webcam C920." It does have the caution sign on it and when I run the troubleshooter it says something about a composite driver error. It still is not recognized in device manager and only shows as "composite device" I have uninstalled this several times and rebooted several times to no change.

I have updated windows and graphics card drivers and anything else I could think of. It also only seems to work on a single USB port on my computer which is a 2.0 front panel port. When I plug it into anything directly into the motherboard, nothing happens. Before I left for the weekend the camera was working fine with zero problems. When I boot my computer up I get a ton of USB connect and disconnect sounds until it's finally recognized and I can see it in control panel but with errors.

Is there anything else I can try? Anymore information you need? Do I need to suck it up and purchase a new webcam?

Thank you!
 

ASK THE COMMUNITY

TRENDING THREADS