• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Logitech C920 webcam stopped working in Win 7 Pro

dg27

Distinguished
Nov 7, 2010
396
10
18,815
7
I've been using a Logitech C920 webcam for a few years; it previously worked great.

Yesterday it stopped working on my Dell XPS 9100. I tried it on two other machines and the camera itself is fine.

It still shows up in Device Manager as working properly. In Sound, it's shown as the default microphone.

I uninstalled and reinstalled the driver.

It's USB, but it's not a USB issue: no matter which port I use it shows up.

When I launch the Logitech software it says:

"We detect your camera is either disconnected or being used by another application, try closing any other application(s) that might be using your camera and then restart Logitech Capture."

Somehow I think a setting in Windows 7 got corrupted and something seems to be blocking access.

I use this to give classes as part of my job, so fixing it is urgent.

Any suggestions of what to check would be greatly appreciated.
 

dg27

Distinguished
Nov 7, 2010
396
10
18,815
7
Thanks, Ralston.

I ran chkdsk /f /r c: on that machine: came up clean.

Checked Reliability: nothing related to Logitech.

Ran sfc /scannow next: it fixed boatloads of errors; the CBS log is huge, but it's all Greek to me.

No change regarding the camera.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS