Question Logitech F310 controller stopped working. I've run out of ideas. Can anybody help?

Jul 25, 2022
1
0
10
0
So about a year ago I got myself a Logitech F310 controller from Best Buy or whatever and when I plugged it in, it worked fine immediately. In all that time, it worked fine. A few days ago, I unplugged it because the cord became tangled with my headphones cable and when I plugged it back in, there was no chime which I'd normally hear when plugging in a new device. I checked the device manager/devices and printers and it doesn't show up there at all.

I switched the x/d input back and forth in case that might be an issue (no idea why it would be, but..just in case)
I restarted my pc (a few times)
I downloaded the driver software or whatever directly from the logitech website and it says it doesn't detect any gamepads (lgs510)

So then I thought maybe it's just faulty hardware. Maybe something inside the plastic casing is busted, so I plugged it into another computer confident that it wouldn't work. It did.

So then I figured maybe it was just a faulty port. I plugged it into other ports. Nothing. I unplugged my mouse and keyboard and my headset and plugged the gamepad into each of their slots. Nothing. I plugged the mouse and keyboard and headset into different slots. They all worked fine. So my usb ports are fine..

Then I remembered i have four usb ports that didn't work for various reasons (abuse, mostly. I'm a big oaf and I like to be forceful because it makes me feel like a man). I plugged it into one of those broken ports and....it works? But if I plug anything else there it doesn't work...

Now I'm stumped and so I went to a logitech support agent and they cycled me through everything I previously did and then told me the problem was my computer, not their hardware. Probably right. But I still thought I should make a post here in case anybody else had a solution I didn't think of.
 

ASK THE COMMUNITY