Question Logitech mouse speed goes back to default after inactivity

Mar 26, 2022
5
1
15
0
Hi everyone, I have a Logitech G Pro Wireless Mouse

I have been using Logitech G hub to customize the DPI (which makes my mouse move faster). When I leave my mouse inactive for a few minutes and when I move it again, the mouse speed will be at the default speed (without DPI), then after like 2 seconds the speed will be back to normal (with DPI).

Does anyone know why this is happening? I have also noticed my mouse speed is at the default speed when I am at the login screen when I boot up my computer as well. Is anyone also experiencing this?

Thank you,
 

dwd999

Honorable
Hi everyone, I have a Logitech G Pro Wireless Mouse

I have been using Logitech G hub to customize the DPI (which makes my mouse move faster). When I leave my mouse inactive for a few minutes and when I move it again, the mouse speed will be at the default speed (without DPI), then after like 2 seconds the speed will be back to normal (with DPI).

Does anyone know why this is happening? I have also noticed my mouse speed is at the default speed when I am at the login screen when I boot up my computer as well. Is anyone also experiencing this?
Is this with the 3/22/2022 hub software update; just in case its a software bug solved by the update. Also just in case your mouse and g hub are shutting off when they're idle, you could check the Control Panel Power Options to make sure everything is set to 100 percent Maximum, and also the Device Manager Properties for all mouse and usb related devices to make sure the Power Management options "Allow the computer to turn off this device" is UNchecked. Also you could check the Control Panel Mouse options to see if the Pointer Options Speed setting is conflicting with the G hub; try setting that to maximum. Also since G hub is a software booster that runs after Windows starts up you shouldn't expect your dpi boost prior to logging in and the g hub software loading.
 
Mar 26, 2022
5
1
15
0
I'm currently using the 2022.3 Released on March 22, 2022, so i don't think it's a software bug. In the device manager however i couldn't find my mouse, i've checked under the "Human Interface Devices", and "Mice and other pointing devices", but still nothing.

Also you could check the Control Panel Mouse options to see if the Pointer Options Speed setting is conflicting with the G hub; try setting that to maximum.
I've set this to maximum, and my mouse speed changes, but in the software it is still the same DPI, could this be the problem? if so how do I disable it?
 
Mar 26, 2022
5
1
15
0
Also since G hub is a software booster that runs after Windows starts up you shouldn't expect your dpi boost prior to logging in and the g hub software loading.
If you use the On-Board Memory Mode, windows will boot up with your dpi boost, but it still doesn't fix the "Idle" issue, which is a way bigger problem for me.
 

dwd999

Honorable
If you use the On-Board Memory Mode, windows will boot up with your dpi boost, but it still doesn't fix the "Idle" issue, which is a way bigger problem for me.
Since your mouse doesn't show up under HID and the usual Mouse devices, you'll have to go through every usb device and port listed on the bottom of the Device Manager screen. The idle issue sounds like one of those usb settings is turning off the usb port your mouse is connected to so you'll have to check each one until you're sure that none of them are turning off any usb ports. Also the Control Panel Power Options USB Selective Suspend setting should be Disabled.
 
Mar 26, 2022
5
1
15
0
In Device Manager > View tab double check that Show hidden devices is selected.
I've tried that in the beginning, but thank you anyways!

Since your mouse doesn't show up under HID and the usual Mouse devices, you'll have to go through every usb device and port listed on the bottom of the Device Manager screen. The idle issue sounds like one of those usb settings is turning off the usb port your mouse is connected to so you'll have to check each one until you're sure that none of them are turning off any usb ports. Also the Control Panel Power Options USB Selective Suspend setting should be Disabled.
I've tried everything you've said, and another important thing to mention is that i'm left handed so i swith the primary and secondary click in the software. After not using my mouse for a couple of minutes it goes idle as usual but when i move it, the primary and secondary clicks stay the same (as to what I set it to in the software), and the lightning goes instantly to what I set it to in the software, but the DPI boost only changes after like 2 seconds.
 

dwd999

Honorable
I've tried that in the beginning, but thank you anyways!


I've tried everything you've said, and another important thing to mention is that i'm left handed so i swith the primary and secondary click in the software. After not using my mouse for a couple of minutes it goes idle as usual but when i move it, the primary and secondary clicks stay the same (as to what I set it to in the software), and the lightning goes instantly to what I set it to in the software, but the DPI boost only changes after like 2 seconds.
All that's left is to report it as a bug in the logitech software; hopefully they'll fix it.
 

dwd999

Honorable
Just offering a thought:

This per @dwd999

"Since your mouse doesn't show up under HID and the usual Mouse devices "

@niimrodd

In Device Manager > View tab double check that Show hidden devices is selected.
This is the problem with mice and keyboards being connected via usb dongles; you never know which usb device its connected to in the device manager. Its also one of my pet peeves about windows where microsoft just decides on its own that some devices, especially usb ports, should have their power management options set to "Allow the computer to turn off the device" even though you've selected the High Performance power plan.
 
Mar 26, 2022
5
1
15
0
This is the problem with mice and keyboards being connected via usb dongles; you never know which usb device its connected to in the device manager. Its also one of my pet peeves about windows where microsoft just decides on its own that some devices, especially usb ports, should have their power management options set to "Allow the computer to turn off the device" even though you've selected the High Performance power plan.
Don't ask me how, but somehow it works perfectly, thank you really for your help.
 
Reactions: dwd999

ASK THE COMMUNITY