• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Losing control of H150i in iCUE after Windows sleep mode

JayGau

Reputable
Dec 20, 2016
53
6
4,535
0
Since the RGB lights of my Kraken X52 died last week I thought it was time to buy a 360mm so I ordered a Corsair H150i XT Pro. I installed it and everything looked just fine until my computer went to sleep and woke up. Looks like the cooler is no longer enabled in iCUE after sleep and whatever I do has no effect anymore (neither light effects or fan curves can be changed and all I can see on the pump is the hardware lightning effect). I tried to just close and restart iCUE but the only thing it does is to make the H150i disappear from the list of available devices, showing that there is really some sort of disconnection and I thus need to reboot the computer to have everything back.

I really tried everything I could think of. I uninstalled-reinstalled iCUE and also installed an older version but no effect, still same problem. Since I am using an internal usb hub for the cooler and the node pro (my MB has only one internal usb port so I need to split) I tried to switch the Node Pro and the H150i on the hub connectors since the Node Pro has always been working flawlessly but again, same problem and the H150i control is screwed up after sleep (but the node pro still works on its new connector).

I tried to disable/enable options in power management settings, tried to uncheck the "allow windows to disable this peripheral" for what I think is the usb ports on the hub. I tried to delete the H150i peripheral and reboot. I tried a windows scan and repair "sfc / scannow ". Nothing works and the sleep mode still breaks my cooler controls. The only thing I found that doesn't look normal about the H150i peripheral is in the properties->events: there is a message saying that the device could not be migrated. I searched about that and it seems to be a problem when a driver has not been migrated properly from Windows 7 to Windows 10 but it doesn't make any sense since those devices didn't even exist during the Window 7 era.

I opened a ticket with Corsair today but they said it can take a while before I receive an answer because of covid-19 so I wanted to ask you guys if anyone got a similar issue with the same cooler and iCUE. Any advice?

In the meanwhile I may order a Commander Pro and see if it works better than my usb hub. If it does than I keep it and if it doesn't I return it. It's a shame because I may have to return the H150i if I cannot find a solution within 15 days (Best Buy return window) and I like this cooler.

Thank you for your help!

Edit: I tried several other things this morning like resetting the BIOS to default and returning the to previous Windows version (in case the problem was with the new 2004 version) but no progress at all. I don't think Corsair will reply anytime soon and I am 90% sure that the Commander Pro that I will receive tomorrow will not solve the problem since the header that connects to the pump is nothing else than another usb hub like I already have. Some help would be very appreciated this thing is driving me crazy.

Edit2: Looks like it's my usb hub that cannot handle it... I disconnected it and plugged the cooler directly to the motherboard usb header and it works just fine. Hopefully the commander pro will work otherwise I am screwed.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS