Question Loss of display with freezing

CallumP227

Honorable
Aug 3, 2013
141
0
10,710
5
Hello members of the forum im really in a bit of a pickle atm, a recently built pc (Specs below) will randomly stop outputing a display signal and freeze. by freeze i mean fans etc all still spinning lighting still on etc, but if i push the reset button or hold the power button it wont restart/turn off. i have to turn it off by the plug or back of psu. this has been happening since about january however i have noticed that the last sort of two months it wont freeze but will just restart. i recently borrowed a friends gpu to see if that was the issue (Yes i changed drivers properly) but the problem persists. any ideas? Thanks.
ps, have tried setting bios to defaults incase it was something i did but still the same.
https://uk.pcpartpicker.com/list/cTrMjy
 
This sounds like it could be a PSU issue.
Does the issue still occur in safe mode?

Are there any errors in your event viewer excluding error 41 (kernel power) errors?
(As a side note, 1000W is waaaaaaaaay more than you need.)

I would swap out PSU initially, random reboots can be indicative of power issue.
 

CallumP227

Honorable
Aug 3, 2013
141
0
10,710
5
I have not tried it in safe mode but just ckecked event viewer and error 41 kernal-power is there. Also i know the psu is overkill but i got a good deal on it. and with its warrenty i thought i may keep it for a good few years. the GPU has since been changed for a Strix 970 and will be changed again when navi releases.
 

ASK THE COMMUNITY

TRENDING THREADS