Question Loss of HDMI audio after updating GPU driver?

Nov 10, 2019
5
0
10
0
After noticing it'd been ages since I updated my Radeon driver (I had apparently turned off auto updates), I allowed the driver to update. Without meaning to I hit the 'clean install' option which of course, now, means I had no option for rollback. So after updating the driver, audio for my TV, connected via HDMI directly into my Radeon RX 560, no longer shows up as an audio device at all- not simply, deactivated under sound devices or something, it simply doesn't exist. My PC speakers suck but my TV has a great stereo system set up to it, thus I had been using it for a while as my audio output. Research has turned up nothing and minor fixes like uninstalling both the GPU drivers and audio drivers and reinstalling them have not lead to any success. I'm at a total loss at this point and could really use some advice.
My TV is an old Sony KDL-46W3000 and is connected directly to my RX 560 via HDMI.
My monitor is an Acer V246HL, connected via DVI directly to my RX 560. Audio only available currently through my USB headset or via the motherboard's audio jacks.
 
Nov 10, 2019
5
0
10
0
What do you see listed under "Control Panel > Sound > Playback"?
Have you right-clicked "Speakers" and check-marked "Show Disabled Devices"?
View: https://imgur.com/a/LQYgx9Z

Here's what I got.
Again, before this update happened, my TV showed up as an audio device simply labeled "SONYTV-HDMI" or something along those lines. That has ceased to appear anywhere- not under sound devices here, not under device manager, not even using a TPP like Speccy.
 
Nov 10, 2019
5
0
10
0
Try going to "PC Settings > System > Sound > Manage Sound Devices". Is your TV listed there?
Try going to "PC Settings > System > Display > Multiple Displays > Detect". You can also look in "Advance Display Settings"
My TV is not listed under Manage Sound Devices, but it shows up fine under display settings. It's had no issues receiving video signal over HDMI since the update, this has strictly been a sound issue.
 
When you updated the video card drivers did it install "AMD Radeon Settings" software?
If you go to "AMD Radeon Setttings > System > Software > AMD Audio Driver Version", does it say "Audio Driver is NOT AVAILABLE"?

So what do you have listed under "Device Manager > Sound, video and game controllers"? Any yellow warning signs?
 
Nov 10, 2019
5
0
10
0
When you updated the video card drivers did it install "AMD Radeon Settings" software?
If you go to "AMD Radeon Setttings > System > Software > AMD Audio Driver Version", does it say "Audio Driver is NOT AVAILABLE"?

So what do you have listed under "Device Manager > Sound, video and game controllers"? Any yellow warning signs?
View: https://imgur.com/a/0wfSEXo


No warning signs, no other device shows up. And you can see there's no warning on the AMD settings window.

Again, this is what I mean about it acting like it doesn't exist. It's treating the TV as if it was a generic monitor maybe, not something that can do audio at all. Will check display drivers.
 
Thread starter Similar threads Forum Replies Date
I Displays 1
G Displays 6
D Displays 13

ASK THE COMMUNITY

TRENDING THREADS