loss of sound

Rixblix

Distinguished
Apr 14, 2003
10
0
18,510
I have an ASUS A7N8X Deluxe revision 1.06. Recently the sound ont the system dropped out. After trouble shooting I discovered that the system was only seeing 1 stick of my Corsair ram. on rebooting I got a CMOS error, then a system filed memory check. First I reset the BIOS, which got me up without sound and missing 256 RAM again. Replaced the battery onbord and fixed the CMOS error, but still no sound and still only 1 stick recognized. Thinking BIOS corrupted by battery loss I reluctantly flashed the BIOS. No improvement. Now for the really wierd part. In the hardware manager, my sound devices are listed and they are listed as working correctly. I tried putting in a brand new sound blaster I had and it is recognized by hardware manager but for both onboard sound and the pci card (enabled separately) in control panel no device is recognized. As for the memory, Sis Sandra sees both sticks but in general info in Windows only 256. I tested both sticks separately also both slots and everything works.
So, isthis this a windows problem or a BIOS problem? drivers?