Question Loss of video signal when running certain games

Apr 30, 2021
2
0
10
0
GTX970

Certain games only: The game loads into the menu, I try to load a save game and suddenly the screen goes black - loss of video signal. PC is still on. Can only resolve by resetting the PC. Happens consistently every time with certain games. Some will actually get into the game for a short while before losing signal.

I have narrowed this down to a graphics card problem, as I have swapped the card to another machine and the problem is just the same in the other (newer) computer

I think that is also a good indication that it must be hardware, rather than driver related ?

I've had this card since release, its been good. What's bugging me is that it only affects SOME games.

It also doesn't seem to be related to how demanding a game is, because it will happily run Titanfall 2 on maximum settings, but it fails on some much less demanding stuff.

I've had the card out, cleaned it. No obvious issues. The fans spin when it's in use.

I am a bit baffled, and was resigned to just getting a new card but have since discovered that is nigh on impossible, so wanted to ask if anyone could offer any suggestion as to what the problem might be, how to diagnose the problem, and if this could be fixed or if the card is screwed.

Thanks
 

David0ne86

Upstanding
Mar 11, 2021
326
84
290
10
Think it's just the card starting to fail. Because if it presents the same issues on another build, the sole culprit can be the card. Why only on certain games? That i don't know. But the card is definitely the problem here. Have you recently update its drivers? If yes and the problem started occurinfg then, Have you tried older driver versions? Also have you correctly removed the previous with DDU? I know obvious question, but hey.
 
Apr 30, 2021
2
0
10
0
Hi David, thanks and apologies for not putting this into the OP

Yes I used DDU to remove the drivers and full reinstall of the latest version. Also behaves the same (same games fail) on the other machine (which had a different nVidia card).

I can't see any other answer other than card starting to die, talk about bad timing
 

David0ne86

Upstanding
Mar 11, 2021
326
84
290
10
Yup, rip buddy. As i said, if you get the same issues on a different build, it's def the card. I still would try the last thing and use some older drivers version before completely resign to the idea it's the card going kaput.
 

ASK THE COMMUNITY

TRENDING THREADS