Question Lost between Drivers failing or GPU dying, and what to do if either is the case [GTX 1070]

Dec 26, 2018
3
0
10
0
I have a GTX 1070 that I have had for around 3 years. One morning, I turned my PC on and everything started to stutter every 2 seconds, or General Freeze, from what I see people call it. It would freeze for like half a second and go back to normal for 2 seconds, and back to freeze, etc. I thought "Welp, something went corrupt." and did a bit of troubleshooting, with my SSD, Windows 10, and other parts. I ended up resetting Windows and everything worked fine. The part that loses me is when I install drivers for the GTX 1070.

I installed GTX 1070 drivers and the stutter came back, so I thought maybe it was the new update. I deleted the drivers completely and went back to an earlier version I knew worked. The stutter came back. The thing is, if I uninstall the drivers, sometimes the screen will change to a random tint of color, making it hard to see the screen well. That is what makes me confused on whether or not my GPU is dying or Drivers aren't working. It would change to a tint of Red, Yellow, and even Purple at one point.

When reinstalling Windows and Drivers, now I get an error every so often that my drivers cant be installed because they aren't compatible with my version of Windows? Which is odd, knowing I have Windows 10 64 bit and also the exact drivers for that version of windows. It got to a point when installing GeForce Experience couldn't detect my GPU. That was an easy fix as uninstalling the drivers fixed the issue.

Another thing I would point out is that I did NOT install drivers the night before this happened. I woke up, turned my PC on, and it started to stutter, like explained above.

Here are main issue points to help without reading:

-Before installing Driver, it would run w/o a stutter
-Trying to install drivers would say that "It isn't compatible with your version of Windows" even though the version I have is completely fine
-GeForce Experience wouldn't detect GPU until I uninstalled old drivers
- A random color tint would come up when drivers were uninstalled
-The drivers would cause a stutter
-I have started stuttering without updating drivers the night before

I have not the slightest idea if this is a GPU issue or drivers being a pain in the ass, but if either of these are the issue, how should I further take action?

Any help with the issue would be great :) And if any extra information is needed, I will gladly give...


EDIT: My PC Specs In case it mattered:
CPU: Intel i7-6700k
GPU: GTX 1070
MOBO: MSI Z170A Gaming M5
PSU: PSU: EVGA SuperNOVA NEX 650 W 80+ Gold
RAM: G.Skill Ripjaws V Series 16 GB
STORAGE #1: Samsung 850 EVO 250 GB
STORAGE #2: Seagate Baracuda 2 TB
OS: Windows 10 64 bit: Version 1903
 
Last edited:
Jul 25, 2019
10
0
10
0
As the old drivers dont work aswell it should be something else. "It isn't compatible with your version of Windows" mostly means 32bit or 64bit, plz check which u use.
Sofware: unprobable since u already made a clean new win installation.
Hardware: Can u test with another GPU?
Might be PSU aswell, though not as likely.
Mobo next. Else very unlikely.
Also give us the full specs plz
 
Dec 26, 2018
3
0
10
0
Also give us the full specs plz
Sorry about not giving specs previously, here they are below:
CPU: Intel i7-6700k
GPU: GTX 1070
MOBO: MSI Z170A Gaming M5
PSU: PSU: EVGA SuperNOVA NEX 650 W 80+ Gold
RAM: G.Skill Ripjaws V Series 16 GB
STORAGE #1: Samsung 850 EVO 250 GB
STORAGE #2: Seagate Baracuda 2 TB
OS: Windows 10 64 bit: Version 1903
 

ASK THE COMMUNITY

TRENDING THREADS