• Enter here for a chance to win a custom MechWarrior 5: Mercenaries themed PC powered by Intel!

Question Low FPS in Cod:WZ Sapphire Radeon RX580 4GB

woodrow888

Reputable
Feb 4, 2018
15
1
4,515
0
Hey!

I have been reading threads about having low fps (50-60fps on low settings) in Cod:WZ and realized i am having problem with the PCI-E lanes.

System: Win 10 up to date.

PC specs:
  • MOBO: Gigabyte B450 Aorus M mATX
  • CPU: Ryzen 5 2400G
  • RAM: G.Skill 2x8GB 3000mhz
  • GPU: Sapphire Radeon RX580 4GB
  • Sata SSD: Kingston ssdNow v300 60GB (system drive)
  • NVMe SSD: Kingston A2000 250GB M.2
  • PSU: XFX TS 650W
See the link below, GPU-Z shows that the GPU is running at x8.

https://ibb.co/zGy0W32

Seeking for some advice how to overcome this problem, and fully utilise the x16 PCI-E lane.

Thank you in advance.
 

woodrow888

Reputable
Feb 4, 2018
15
1
4,515
0
What CPU cooler do you have? What case fans do you have?
CPU cooler is the stock AMD, i have a Bitfenix Pandora mATX case (case fans are Bitfenix aswell). It is far from the best ventilation, sometimes i am using the case without its side panel.
Note here, that i have a Arctic Freezer CPU cooler.
As --SID-- pointed out, i am probably going to upgrade to a better CPU and place the aftermarket cooler on it.
 

Phaaze88

Titan
Ambassador
RX 580 doesn't saturate PCIe 3.0 x8, so I doubt that's really affecting performance here.
Probable culprits, or combination of:
-Ram: already pointed out
-Cpu thermal throttling: already pointed out
-Kingston V300: it's the C drive, which is full, and likely one of those dramless drives.
-Whether or not the game is installed on the WD Blue or Kingston A2000: if it's on the WD Blue, and 100% disk usage is observed in Task Manager, then it needs to go on a faster drive.
 

woodrow888

Reputable
Feb 4, 2018
15
1
4,515
0
RX 580 doesn't saturate PCIe 3.0 x8, so I doubt that's really affecting performance here.
Probable culprits, or combination of:
-Ram: already pointed out
-Cpu thermal throttling: already pointed out
-Kingston V300: it's the C drive, which is full, and likely one of those dramless drives.
-Whether or not the game is installed on the WD Blue or Kingston A2000: if it's on the WD Blue, and 100% disk usage is observed in Task Manager, then it needs to go on a faster drive.
Thank you for your help and suggestion!
 

woodrow888

Reputable
Feb 4, 2018
15
1
4,515
0
So i have made a couple of adjustements and the results is decent:
Ram: Enabled XMP so it runs as it supposed to.
Cpu: until i change the cpu and the cooler, took the side panel off for some extra and well needed air :)
SSD: Moved the game from the old HDD to the NVMe SDD.

Latest Userbenchmark test, best so far: https://www.userbenchmark.com/UserRun/42442031

This got me an extra 15-25 FPS so far.

Thanks for all of your help!
I can consider this thread solved!
 
Last edited:
Reactions: Phaaze88

ASK THE COMMUNITY

TRENDING THREADS