[SOLVED] Low FPS in games (such as GTA V and Overwatch)

Dec 14, 2020
9
1
10
0
My PC build isn't all that new or anything, but I don't think these games should be completely impossible to play in the lowest graphics settings.

My specs are GeForce GTX 1660 Ti, Intel Core i5-9400, 8 GB RAM.

Malwarebytes & superantispyware don't bring up any issues.
Background programs are always closed before I play, and I even tried having programs suppress hidden ones.
My computer is set to high performance, and my NVIDIA settings are set to make 3D graphics as easy as possible.
My GPU drivers are completely up-to-date.

Despite all this, I can hardly move in these games. I only get slideshows out of them, and it gets worse over time. My computers temperature doesn't get high, and it doesn't seem like any hardware is reaching anywhere near it's limit.
Other games such as Minecraft are fine.

Please help me troubleshoot this.
 
Dec 14, 2020
9
1
10
0
GPU temp stays roughly at 43 with usually 1-2% usage according to task manager, and maxes at 15% according to msi afterburner.
CPU usage is about 50% while playing, temperature is about 50-60.
RAM usage is about 7.6/8, never goes over 7.7.
Power usage is about 20% at all times.

What caught my attention most from checking those things is my PC uses HDD and during lag spikes it gets 100% usage. My HDD is "ST1000DM010-2EP102," which apparently has a read speed of 210mb/s. I'm guessing that's the problem, then? Would upgrading to a good SSD (and maybe increasing RAM) fix the lag, do you think?

If that's the case, I could use some SSD recommendations for my build. I don't know much about that stuff and don't want to make things worse for myself.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS