low fps in nfs

dethead

Distinguished
Nov 20, 2003
6
0
18,510
i have been playing the need for speed underground demo for a week and i have tried mny configurations but i get the game runnig at a really slow speed .i have tie it in two pcs mine is a p4 1.8 with a gforce4 ti 4200 and the other a athlonxp 2400 with a radeon 9200 both with 512 ram. acoording to ea the game should run at full graphics with a p4 1.6 and a 64mb of video memory.
 

Vapor

Distinguished
Jun 11, 2001
2,206
0
19,780
EHHHHH.....when they say full graphics, they mean full detail, but at a VERY low resolution, not 1600x1200, full detail, 6xAA and 16xAniso. I run mine at 2xAA, full details, 1024x768 and only get around 25FPS (I have a 2.66B, 1GB PC1066 RAM, Ti4400 @ 300, 600). To be honest, I would doubt that a 1.6P4 and 64mb of video memory could even pull off full detail at 640x480. They just say that to sell the game to people who don't have the best system available. You also should turn off motion blur and light trails on your systems, anytime you use NOS or go above 150, your FPS will plummet, subsequently losing control when you need it most.

Also, don't complain about low FPS in here unless you plan to make a purchase and want help on a decision. The 9200 is a pretty bad card and you can't expect much out of it. The Ti4200 is pretty good, but gets destroyed by that game and many other new games. I would swap the 4200 and 9200, you'd get more performance for your AXP system.

Damn Rambus.
 

dethead

Distinguished
Nov 20, 2003
6
0
18,510
i got low fps even in at 1024 x 768
i know that my ti4200 is outdated but the game should run fine.
nfs underground is a multiplataform and if the game can run with almost the same graphics of a pc in a ps2 the pc sholdnt have any problems.
 

Vapor

Distinguished
Jun 11, 2001
2,206
0
19,780
At what detail settings were you running at 1024x768??
Not to be offensive, but don't expect too much from either of your systems. To improve, I'd put your 4200 in your AXP system; the 4200 is better than your 9200.
Don't get any of us started on multiplatform conflicts. PS2 and PCs are two completely different beasts. Sure the PS2 is 'slower' than your PCs, but it is also a stagnant platform (i.e., it isn't a moving target for developemnt), only outputs at 640x480 resolution and is a completely different beast in terms of architecture, processes, and software. It's not even comparing apples to oranges, it's comparing apples to beef.

Damn Rambus.
 

coylter

Distinguished
Sep 12, 2003
1,322
0
19,280
its running smooth as butter for me
at 1280x1024(max screen res) and full setting + 6x aa 16x ani

My own beast: Athlon 2700xp+ , Radeon 9800pro (oc: 410/370) , 512mb ddr400. SO MUCH faster than my father pIII 550......
 

Vapor

Distinguished
Jun 11, 2001
2,206
0
19,780
You have a 9800Pro OCed...and a very nice processor, good FPS are expected. 25FPS is smooth as butter for me (IMO, racing games never need many fps, I go more off of a feel than what I see). I checked and I'm actually running 1280x960, full details, 2xAA and it is smooth. IMO, not too bad from a system that graphically isn't nearly as powerful as yours.

Damn Rambus.