[SOLVED] low FPS with beast PC?

Apr 1, 2019
7
1
15
0
hello guys, please tell me what I am doing wrong....

I tried to play a game called theHunter call of the wild and I quickly noticed I only got 30fps on ultra.??
same stuff with Ark survival evolved, ultra settings and playing with 45ish FPS.

best part is this... My PC:
i7 9700K OC to 5GHZ 1.34 VOLT stable
got enough cooling with a corsair h150i pro rgb, wont exceed the 50C

1080 TI aorus. this problem happens WITH and WITHOUT an overclock. thbe extra OC I use on my GPU is:
+50 on the core
+500 on the MEM
150% power limit

16 GB corsair vengeance DDR4 2133MHZ

gigabyte aorus ELITE z390

I am gaming at 1080P.- should be no issue
I have the most up to date BIOS, most up to date drivers.

I have tried:
older drivers- didn't work
newest drivers- didn't work
remove overclock on everything- didn't work
tried overclock on just some parts- didn't work.
reinstall windows- didn't work
Disable vsync- didnt work
Changed to windowed and fullscreen- didnt work

GPU doesn't exceed 71 C. for some reason after a little while in the game my GPU acts like it has no stress, shows a HUGE fps drop and is chilling at 60~C.

In short:
CPU: i7 9700k 5GHZ OC - 1.34Voltz
GPU: gtx 1080 ti gigabyte aorus
Motherboard: gigabyte aorus elite z390
RAM: 16gb corsair vengeance DDR4 2133mhz
Cooler: corsair h150i pro rgb
PSU: corsair hx850 v2
Case: phanteks p400s tempered glass
2 monitors 27" running 1080P (first monitor is 75hz)

PLEASE HELP, im all out of ideas
 
Last edited:

KenshiroHnK

Commendable
Nov 23, 2016
24
0
1,520
1
try disable Vsync in game and nvidia drivers. also try full screen or windowd. try too in nvidia settings or game variable fps if has the option.
 

KenshiroHnK

Commendable
Nov 23, 2016
24
0
1,520
1
weird i had aorus 1070 played ffxv on max and ac origins on max too. try on windows power settigns to max. not sure if this will help but if you had old drivers and a new video card try to uninstall drivers using DDU. one last thing check in your sistem admin if the only card driver is your Gtx 1080 and not your CPU. this happens more on laptos
 
Apr 1, 2019
7
1
15
0
weird i had aorus 1070 played ffxv on max and ac origins on max too. try on windows power settigns to max. not sure if this will help but if you had old drivers and a new video card try to uninstall drivers using DDU. one last thing check in your sistem admin if the only card driver is your Gtx 1080 and not your CPU. this happens more on laptos
I will try doing that later today. Thanks already, i will update when i did
 
Apr 1, 2019
7
1
15
0
weird i had aorus 1070 played ffxv on max and ac origins on max too. try on windows power settigns to max. not sure if this will help but if you had old drivers and a new video card try to uninstall drivers using DDU. one last thing check in your sistem admin if the only card driver is your Gtx 1080 and not your CPU. this happens more on laptos
WOW!, this actually helped! my intel graphic drivers were interfering with my nvidia drivers, running full 100 FPS now thanks!
 
Reactions: KenshiroHnK

ASK THE COMMUNITY