Question Low GPU & CPU Utilization on New Build. Is it the Game or my PC?

Jun 15, 2022
5
0
10
0
Hello,
Just finished building this system (i5-12600K with RTX 3080) and I'm getting worse performance on a certain game (Battlefield 2042) than my old system with a gtx 1080.

Here is my userbench: https://www.userbenchmark.com/UserRun/53244863

Is the problem with the game or my system?

In the game im getting around 50-70 fps at best and 40-50% gpu/cpu utilization on low settings. I'd expect at least 100fps with this build. My 1080 system got 70-80 stable with 100% gpu utilization.

Again, is it the game or is it my system? I'd appreciate any help. Thanks
 

faalin

Judicious
2 things......first you're only using a single stick of ram so that is killing performance. If you can, try and return it and get a 2x8GB kit or you can try and push your luck and pick up another stick and try to pair them. Note that putting two sticks together that are not from a kit is like a crap shoot, you have a 50/50 shot that it will work or not.

Second you need to turn on XMP in the bios so the ram is running at 3200Mhz and not 2133Mhz
 
Reactions: EightiesKid78
Jun 15, 2022
5
0
10
0
2 things......first you're only using a single stick of ram so that is killing performance. If you can, try and return it and get a 2x8GB kit or you can try and push your luck and pick up another stick and try to pair them. Note that putting two sticks together that are not from a kit is like a crap shoot, you have a 50/50 shot that it will work or not.

Second you need to turn on XMP in the bios so the ram is running at 3200Mhz and not 2133Mhz
I turned on XMP and it did help some but still not where i want it to be. I have two sticks of ram. Why is only one showing? Maybe I didn't set it all the way. I'll check that next.
 
Jun 15, 2022
5
0
10
0
2 things......first you're only using a single stick of ram so that is killing performance. If you can, try and return it and get a 2x8GB kit or you can try and push your luck and pick up another stick and try to pair them. Note that putting two sticks together that are not from a kit is like a crap shoot, you have a 50/50 shot that it will work or not.

Second you need to turn on XMP in the bios so the ram is running at 3200Mhz and not 2133Mhz
Holy Crap that was it! One of my ram sticks was not all the way seated. I plugged it in, turned on XMP and now im sitting well above 100 fps. Thanks! Love this forum
 

Karadjgne

Titan
Ambassador
You have a 12600k and 3080. Why are you on 'low'? Game presets change 2 things, cpu dependent settings And gpu dependent settings. It'll supposedly give you maximum fps output from the cpu, but minimal graphics, which lowers utilization in a big way.

You shouldn't ever see 100% utilization in either as that simply means that component is maxed out, no headroom for changes or additions, which can kill fps on screen.
 

ASK THE COMMUNITY

TRENDING THREADS