Question Low GPU Usage (<50%) ASUS TUF a15

biraj13

Distinguished
Dec 7, 2012
18
0
18,510
0
Recently got an ASUS TUF A15(Ryzen 7 4800H + RTX 3050 + 16GB). GPU usage always seems to be below 50%, mostly ~30%. Tried Forza Horizon 5, was getting below 15fps. Forza Horizon 4 runs below 40 fps - gpu usage at 30%. PUBG - below 25 fps.
CPU usage also remains in the 50% range.

I am using an external display (2560x1080) via the Display Port (USB C).

Tried changing power options from control panel, changed power and latency settings in Nvidia Control Panel. Have the latest NVidia drivers. Running in Turbo Mode.

Please suggest some solutions.
 

Lutfij

Titan
Moderator
Check and see if your laptop has any BIOS updates pending(using Asus's support page for your laptop). Following that see if your OS is pending any updates. Following that, use DDU to uninstall all of your GPU drivers(AMD as well) and then manually reinstall the latest drivers(sourced from Nvidia's support site) in an elevated command, i.e, Right click installer>Run as Adminsitrator.
 
Reactions: biraj13

biraj13

Distinguished
Dec 7, 2012
18
0
18,510
0
Hey, thanks for responding. I tried that but it didn’t fix the issue. While testing I found out that there is low gpu usage when the gpu clock is high. So when the GPU clock is in the range of 1500Mhz-2000MHz, the usage drops to below 30% and I get unplayable fps. When the clock is in less than 900Mhz, I get 80% and above gpu usage and very good fps. I am currently using afterburner to limit the clock and running the laptop in Silent mode from Armoury Crate. Is there any fix to this?
 

ASK THE COMMUNITY