Question Low GPU usage in some games (RX 570)

Jun 6, 2019
4
0
10
0
Hello
I just got my build done and im already frustrated
So first my gpu usage was spiking from 0% to 100%, 80% etc, very unstable so i saw a thread that said to check "enable unified gpu usage" on afterburner and that helped, the usage looks to be more stable, now the problem is that certain games i cant even get to 100 or even 90 those games are Battlefield 5, GTA 5, Killing Floor 2, Rust and a few more not sure how many more because i havent tested a lot
But there are games that i can get stable 100% usage those are The witcher 3, Sniper Elite 4, Life Is Strange BS, PUBG, Apex Legends, BF4
There are games that in certain scenes or camera mode get 100 usage like American truck Simulator also killing floor 2 get 100 usage when im in the menu but when i enter in a game i get between 70 and 90 usage, rocket league too

I also tested furmark and heaven benchmark and both can get to 100 usage

I have tried a lot of thing but nothing has worked
The only thing left is reisntalling windows

Specs
Ryzen 2600
16GB 3000 (Dual Channel2x8)
Saphire Pulse RX 570
CX550
 
Last edited:
Jun 6, 2019
4
0
10
0
Don't worry about GPU usage. What are your frame rates?
BF5 everything high around 85-100fps depends on the map
GTA is the worst it can go as high as 100fps but as low as 60 almost everything on high, no FXAA, shadow high, wahter hihg, grass high, ambient occlusion and tesselation high everything else very high and the usage can go from 50 to 75
Rust on "fantastic" gets 60-70 fps
Killing floor evrything ultra something like 130-150fps

I would say some of those are fine BUT i would expect more frames because im not even playing on 1080 im playing on 900p im getting lower fps at lower resolution than some benchmarks on youtube
 

ASK THE COMMUNITY

TRENDING THREADS