Question Low performance GPU

Nov 10, 2019
4
0
10
0
I got a problem with my gpu. Every time I update my driver it works fine for a while. However, after a while games start to lag, the only way to fix this seems to be updating or reinstalling the driver again. And the cycle just keeps on going. Does anyone know a solution to this?
My gpu is the radeon rx580.
 
Nov 10, 2019
4
0
10
0
Monitor the cpu/gpu temp with software, like MSI afterburner, or hwinfo, etc.

What PSU did you have? Brand/Model?
I've only had this problem for a few months. Before that everything worked fine.
The temperature doesn't seem to be a problem since I also have this problem when I just started my pc. I have also been monitoring it a few times lately and it has never gone far above 70 degrees celsius which should be fine, right?

My PSU is the be quiet! sytem power SB8-550W
 

cin19

Titan
Moderator
The gpu temp is fine as long as it is not going up higher 80C, and maybe the GPU has problem, because you said you got the same problem when you started the pc too.

Also it maybe the GPU driver too, may try to use DDU to uninstall the driver, then reinstall the driver again. Also may set the gpu power limit little bit low, tweak the voltage little bit higher , sometime it will help the GPU runs more stable.

One more update the AMD chipset driver too. https://www.amd.com/en/support
 
Nov 10, 2019
4
0
10
0
The gpu temp is fine as long as it is not going up higher 80C, and maybe the GPU has problem, because you said you got the same problem when you started the pc too.

Also it maybe the GPU driver too, may try to use DDU to uninstall the driver, then reinstall the driver again. Also may set the gpu power limit little bit low, tweak the voltage little bit higher , sometime it will help the GPU runs more stable.

One more update the AMD chipset driver too. https://www.amd.com/en/support
Where can I set the gpu power limit? I did the other things you said, but it still keeps happening...
 

ASK THE COMMUNITY

TRENDING THREADS