Question Low performance in most games

Nov 27, 2021
11
0
10
0
My setup was the following:
I7 6700k
Windows 10 64x
MoBo Gigabyte X99 gaming 5p
3080 OC edition

I could play most games in High with no issue and just a few games hadm mild stuttering, like The Outer worlds, some stutter and fps drop here and there, but nothing game breaking

I updgraded and my setup is now
Ryzen 9 5900x
MoBo Rog Stryx x570e gaming wifi
3080 OC edition

I had a lot of issues after upgrading to W11, stuttering and massive FPS drop in most games, even non graphic intensive games I clean installed windows 11, and most issues are gone, but I still do not get the performance I know I should (all of the games mentioned are set to ultra and played in 1080p)

AC Odyssey, very mild stutters here and there, FPS goes 60-80 RDR2, mostly solid 75fps, minimal stutter when the fps goes down from 75 to 50ish, but almost never happens

The outer worlds. solid 75 with mild stutters everywhere, still playable but annoying(although this might be because it is optimized for amd afaik)

Control, solid 75, if I uncap it I get up to 180, then I get some stutters when it goes down to 120- 150

Days Gone, 75 with a lot of stutters, especially in the bike, if I lock fps at 60 I get minimal stutters, almost unnoticeable but still there

Elder Scrolls Online... That game can run in a potato, so this is not out of what I would think, but I get solid 120 fps with no stutter or drop, not even in the Dolmens in Alikr(which always see 30-50 players and a lot of on screen effects, or in PVP, both scenarios always tanked my FPS to 25-30 in my previous setup, not now

Fallout 76, this is the most jaw dropping thing, this game is old, and based on FO4, so it should not be demanding, yet I get even worst performance than in TOW or DG, I get 50-60 FPS, and there is no stuttering but the game looks... weird, to the point that I could not play more than 30 mins because I got dizzy, it is not stutters, it is not lag... I can't find the words to describe it, it is kind of, like the images are extremely sharp and moving and turning around makes me feel like... like when you are in a roller coaster that everything moves really fast, IDK how to describe it tbh

I checked with MS Support and after some troubleshooting they say they do not see anything wrong on their end, we did some troubleshooting in other forums, and that is when we decided to go for the Windows clean install, but beyond that everyone that helped was clueless as to what else might be going on(me included) I hope someone here has an idea on what might be happening, Ik the games are playable, but I also know that gaming at 1080p I should not have ANY stutters in ANY game that I tested
 
Nov 27, 2021
11
0
10
0
So, I checked power settings and I was on balanced, so I moved it to High performance and it seems that it is solved, but the temp of the CPU increases dramatically, reaching the 90 that creates thermal throttle, so I guess I need to buy a bigger, better water cooler, because the one I currently have is the Cooler Master Liquid Lite120l
 
try switching to message signal interrupts and set it to high priority on your GPU driver, by default it runs on line based interrupts, which is legacy and it runs on emulated virtual lines in pci-e (INTx emulation)
https://www.intel.co.za/content/dam/www/public/us/en/documents/white-papers/msg-signaled-interrupts-paper.pdf

nvidia doesnt have enabled msi support, but it supports it, on windows it can be enabled through registry editor
here is full guide on how to manualy enable msi support
post there also contains msi utility v3 app, which makes that easier
right click app and run as administrator
click msi, set priority High, then in right top corner click apply
with refresh button you might check if it go applied
then open cmd as admin and type: bcdedit /set x2apicpolicy enable
then reboot

irql latency should be lower
 
Reactions: Leyequois
Nov 27, 2021
11
0
10
0
try switching to message signal interrupts and set it to high priority on your GPU driver, by default it runs on line based interrupts, which is legacy and it runs on emulated virtual lines in pci-e (INTx emulation)
https://www.intel.co.za/content/dam/www/public/us/en/documents/white-papers/msg-signaled-interrupts-paper.pdf

nvidia doesnt have enabled msi support, but it supports it, on windows it can be enabled through registry editor
here is full guide on how to manualy enable msi support
post there also contains msi utility v3 app, which makes that easier
right click app and run as administrator
click msi, set priority High, then in right top corner click apply
with refresh button you might check if it go applied
then open cmd as admin and type: bcdedit /set x2apicpolicy enable
then reboot

irql latency should be lower
I'm guessing that what you mean in the app is the line for the 3080 and change interrupt priority to High right?
https://www.imagebam.com/view/ME5BBO3
 
Nov 27, 2021
11
0
10
0
I did so, and some games got better, but still had some stutter, so I checked and had game mode enabled, disabled it and Days Gone, for example, runs perfect now, but The Outer Worlds and Fallout 76 still have some drops, in the case of TOW it is funny, because I have massive drops with stutter when the game loads, and for 10-15 secs, then it runs 120-160 FPS, and FO76 goes 40-60 with mild stutter, but that one is an online game, so AFAIK the FPS does not depend only on my rig

I am going to test multiple more games, if there is more with stutters... I will cry lol
 
Nov 27, 2021
11
0
10
0
And I tested multiple games, even Metro Exodus with all ultra and RTX enabled gives me 150+ FPS, with any drop having no stutter and being minimal(dropping from 170 to 163-/+)

So I am guessing is some sort of optimization issue in both games (the outer worlds and FO76, which wouldn't be surprising in case of FO76)
 

ASK THE COMMUNITY