• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

Question Low Speed when connection through my Router

Jul 16, 2021
2
0
10
0
Hey guys!

So my problem started when I bought a new ASUS RT-AC750L router and connected it to my ISP's modem. When I connect through my modem ethernet/wifi i would get 390 to 400 Mbps but since my ISP doesn't like it's customers to have full admin access I cant manage my network properly, so I decided to hook up this router. Unfortunately, I would only get 100Mbps thru ethernet and about 40Mbps on wifi, even though my router is rated up to 730Mbps. What could be causing the issue?

I already made sure that the router has the latest firmware is installed.

Any advice you be greatly appreciated.
 
Last edited:

kanewolf

Titan
Moderator
Hey guys!

So my problem started when I bought a new ASUS RT-AC750L router and connected it to my ISP's modem. When I connect through my modem ethernet/wifi i would get 390 to 400 Mbps but since my ISP doesn't like it's customers to have full admin access I cant manage my network properly, so I decided to hook up this router. Unfortunately, I would only get 100Mbps thru ethernet and about 40Mbps on wifi, even though my router is rated up to 730Mbps. What could be causing the issue?

I already made sure that the router has the latest firmware is installed.

Any advice you be greatly appreciated.
Because that router only has 100Mbit wired ports according to ASUS specs -- https://www.asus.com/Networking-IoT-Servers/WiFi-Routers/ASUS-WiFi-Routers/RT-AC750L/techspec/
You need a better router.
Get an AC1200 or AC1900 rated router. They will have gigabit wired ports.
 
Reactions: ZivSuderio

ASK THE COMMUNITY