Question Lower GPU Utilization on Laptop when bypassing Optimus.

Jul 2, 2021
31
2
35
0
I'm hoping one of you guys can help me fix this issue.

First things first. I have an Asus TUF Dash F15 laptop, the FX516PR model that comes with the i7 11375h, the RTX 3070 and 16GB of RAM. Before the latest BIOS updates which I HAVE NOT installed there was a feature in BIOS called dGPU mode which allowed you to bypass Optimus by directly tapping into the Nvidia Chip via HDMI and an external monitor.

I bought an external keyboard and mouse for a little over $100. Both were Razer gaming peripherals. I enabled dGPU mode and plugged into a external 32 inch TV via HDMI and played BFV while using MSI Afterburner and found surprising results:
I'm getting about 10 - 15 less FPS than I did without the external TV connected via HDMI, with occasional spikes into the realm of what I was expecting with the optimus bypass almost as if I was experiencing stuttering of some sort. I tried some other games and got the same results, either lower FPS due to some kind of GPU issue or because the game defaulted the graphics settings into V-Sync to match the TV's 60hz screen.

After looking at Youtube videos I captured of myself gaming on the laptop before and after attaching the monitor using MSI Afterburner I was able to determine that with dGPU engaged and a external display connected, the GPU is seeing lower utilization that it was when I was gaming on the laptop screen. In BFV alone which is the most intensive game I own I saw a drop of 20% in GPU utilization.

I'm hoping one of you can tell me how to fix this issue, I don't know how to go about getting my GPU utilization to go back up to 97-98% with the external display connected.

Just for reference here's the numbers, everything on Ultra Settings.

BFV laptop: 80-90FPS.
BFV External Display: 70-80 FPS with occasional spikes of 100-115 FPS.

FC5 Laptop: 60-70 FPS.
FC5 External Display: 50-60FPS with occasional spikes to 85-90 FPS.

All my older games run at 60FPS when they would normally run at 100+ FPS which I suspect is due to V-Sync.
 
Jul 2, 2021
31
2
35
0
I fixed the issue with most games, some of them were just so old that the game doesn't fully utilize the GPU enough to give me max FPS.

With all of my games I went into Nvidia Control Panel and set each game I play to use the RTX 3070, Under CUDA - GPU's I set it use the RTX 3070/All CUDA Cores. I also made sure the PhysX settings was showing that the RTX 3070 was connected to the HDMI port which it was.

In BFV I had to launch the game, press Windows Key + P and select Second Screen only which vastly improved my GPU utilization.

In Fallout 4 and Oblivion I had to edit the preferences file to disable Vsync manually, and in Far Cry 5 there was nothing I could do because the game is just so d@mn poorly optimized it only uses around 50% of the GPU no matter what I do.
 

ASK THE COMMUNITY

TRENDING THREADS